Music

"Break On Me" - Keith Urban [YouTube Official Lyric Video]

Francesco Marano

by Francesco Marano

Published January 11, 2016

Country star Keith Urban has shared a touching lyric video for "Break On Me," from his upcoming tenth studio album, Ripcord. Listen to it above.

Songwriter Jon Nite spoke with Taste Of Country about writing the song with Ross Copperman and how the lyrics were impacted by taking his daughter to college:

I had this melody for the chorus that I played on guitar. I’d been playing it for about a month on the weekends. I would just try to figure out what it might be. And then Ross and I got canceled on. It was just the two of us, so I played him that melody, and he loved it. We put a groove down and kinda stuck the melody to that, and that became the chorus...

It was right when we were about to leave to take [Nite's daughter, Ashley] off to college for the first time, so I said, "What if we also talked about what would you say to Ashley, when she goes out there and finds out how real life kind of can suck a lot?" We probably talked for two hours just about what felt like and what it sounded like before we really got anything going on it, and then just started talking about days like that girl was having, where she was having a breakdown and was telling Ross. So the first line kinda comes from that, and then it just felt like we were following the emotion of someone who was in a super-not-great place, emotionally, having a depressed moment.

In related news, Keith has announced that he'll be heading out on the road beginning June 2, 2016 for the Ripcord World Tour.

For Keith Urban's latest music, news, and tour dates, check out his Zumic artist page.

Source: Keith Urban VEVO YouTube

0
270
Country Keith Urban Lyrics Video Nashville, TN New Zealand Jon Nite Ross Copperman
сomments
Send Feedback

Hand-Picked Music for Your Taste

Follow artists, discover new music, and personalize your music experience.
JOIN US
Registration and login will only work if you allow cookies. Please check your settings and try again.

OK
Web Analytics