Music

"Jumpin' Jack Flash" - Rolling Stones Live At Hyde Park [YouTube Video]

Brad Bershad

by Brad Bershad

Published October 08, 2013

In this Rolling Stones Hyde Park concert video, "Jumpin' Jack Flash" is performed at an energetic level to the crowd's delight at Hyde Park. 51 years of performing doesn't seem apparent from the group, as they still look young and full of energy on stage. Looking at their past 1969 performance of the song in the same location, not a step is missed in this 2013 footage in front of the hometown crowd.

YouTube Description:

Published on Oct 8, 2013

DVD: http://smarturl.it/RSsweetsummerDVD
DVD+CD: http://smarturl.it/RSsweetsummerDVDCD
DVD+LP: http://smarturl.it/RSsweetsummerDVDLP
Blu-Ray: http://smarturl.it/RSsweetsummerBlu
Deluxe edition: http://smarturl.it/RSsweetsummerDeluxe
Exclusive T-shirt Edition: http://smarturl.it/RSsweetsummerTShirt
Digital Video: Coming Soon iTunes
www.sweetsummersun.com

Available Nov 11th
The Rolling Stones historic and triumphant return to Hyde Park was without doubt the event of the summer. Over 100,000 delirious fans of all ages packed into the park for two spectacular outdoor concerts to watch Mick Jagger, Keith Richards, Charlie Watts and Ronnie Wood do what they do best. The Stones delivered a five star performance that had both fans and critics singing their praises. The set packed in hit after hit and saw the band joined by former guitarist Mick Taylor for a special guest appearance on two songs. This stunning concert film is the perfect way to celebrate the return of The Rolling Stones back where they truly belong: live on stage in their hometown.

 

 The-Rolling-Stones-Jumpin'-Jack-Flash-Sweet-Summer-Sun-Hyde-Park-Live

Source : Rolling Stones YouTube Channel

0
208
artists
The Rolling Stones
genres
Blues Rock Hard-Rock Rock
сomments
Send Feedback

Hand-Picked Music for Your Taste

Follow artists, discover new music, and personalize your music experience.
JOIN US
Registration and login will only work if you allow cookies. Please check your settings and try again.

OK
Web Analytics