<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<base href="/">
<meta name="csrf-token" content="UHriw1dMSNgpsYDx4D9u9PQAshd4t5yMr1jhx7tg">
<meta name="HandheldFriendly" content="True">
<meta name="MobileOptimized" content="320">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
<script src="/cdn-cgi/apps/head/7d4GV02yB8UdnoUCk4VPVdvY-v4.js"></script><link rel="apple-touch-icon" sizes="57x57" href="/favicon/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/favicon/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/favicon/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/favicon/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/favicon/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/favicon/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/favicon/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/favicon/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/favicon/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="/favicon/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="/favicon/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon/favicon-16x16.png">
<link rel="manifest" href="/favicon/manifest.json">
<link rel="preload" href="/assets/css/fonts/Lato-Bold.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/Lato-Regular.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/Lato-Black.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/Lato-Italic.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/font-icon/font-icon.woff" as="font" type="font/woff" crossorigin>
<style>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</style>
<script>
    /**
     * Load Firebase Component
     */
    function loadModule() {
        return new Promise(resolve => {
            const script = document.createElement('script');
            script.src = 'https://www.gstatic.com/firebasejs/5.2.0/firebase.js';
            script.async = true;
            script.defer = true;
            script.onload = () => resolve();
            script.onerror = () => {
                throw new Error();
            };
            document.head.appendChild(script);
        });
    }

    loadModule() // <-- Output firebase-app from https://github.com/firebase/firebase-js-sdk/pull/15
        .then(() => {
            firebase.initializeApp({
                apiKey: "AIzaSyCGC3cf0LlHNT27Fm_KtV0opMUCw3i3V7k",
                authDomain: "zumic-mobile-app-notifications.firebaseapp.com",
                databaseURL: "https://zumic-mobile-app-notifications.firebaseio.com",
                projectId: "zumic-mobile-app-notifications",
                storageBucket: "zumic-mobile-app-notifications.appspot.com",
                messagingSenderId: "792731844860"
            });
        });

    function initMap() {
        if (document.getElementById('location-autocomplete')) {
            setTimeout(function () {
                console.log('init map');
                googleInit();
            }, 2000);
        }
    }

    if ('serviceWorker' in navigator) {
        navigator.serviceWorker.register('/sw.js?v=1594992418', {scope: '/'})
            .then(function (registration) {
                console.log('Service Worker Registered');
            })
            .catch(error => console.log('SW error: ' + error));

        navigator.serviceWorker.ready.then(function (registration) {
            console.log('Service Worker Ready');
        });
    } else {
        console.log('Service Worker registration error');
    }
</script>
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/favicon/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">
<title>Rod Stewart Extends 2022 Tour Dates: Ticket Presale Code & On-Sale Info | Zumic | Music News, Tour Dates, Ticket Presale Info, and More</title>
<meta name="description" content="Rocking with Cheap Trick this summer in America, plus tours of Australia, New Zealand, the UK, and Ireland. This summer, classic rock legends Rod Stewart and Cheap Trick will be touring North America together.  In March, Rod heads out on a tour through Australia and New Zealand before returning ...">
<meta name="original-source" content="https://zumic.com/rod-stewart-extends-2022-tour-dates-ticket-presale-code-and-on-sale-info">
<meta name="robots" content="index">
<meta property="fb:app_id" content="421078361357832">
<meta property="og:locale" content="en_US">
<meta property="og:title" content="Rod Stewart Extends 2022 Tour Dates: Ticket Presale Code &amp; On-Sale Info | Zumic | Music News, Tour Dates, Ticket Presale Info, and More">
<meta property="og:type" content="article">
<meta property="og:description" content="Rocking with Cheap Trick this summer in America, plus tours of Australia, New Zealand, the UK, and Ireland. This summer, classic rock legends Rod Stewart and Cheap Trick will be touring North America together.  In March, Rod heads out on a tour through Australia and New Zealand before returning ...">
<meta property="og:url" content="https://zumic.com/rod-stewart-extends-2022-tour-dates-ticket-presale-code-and-on-sale-info">
<meta property="og:site_name" content="Zumic">
<meta property="og:updated_time" content="2022-02-19T06:37:29-05:00">
<meta property="og:image:width" content="1200">
<meta property="og:image:height" content="627">
<meta property="og:image" content="https://zumic.com/wp-content/uploads/2021/10/rod-stewart-cheap-trick-xfinity-center-mansfield-2022.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Rod Stewart Extends 2022 Tour Dates: Ticket Presale Code &amp; On-Sale Info | Zumic | Music News, Tour Dates, Ticket Presale Info, and More">
<meta name="twitter:description" content="Rocking with Cheap Trick this summer in America, plus tours of Australia, New Zealand, the UK, and Ireland. This summer, classic rock legends Rod Stewart and Cheap Trick will be touring North America together.  In March, Rod heads out on a tour through Australia and New Zealand before returning ...">
<meta name="twitter:site" content="@zumic">
<meta name="twitter:image" content="https://zumic.com/wp-content/uploads/2021/10/rod-stewart-cheap-trick-xfinity-center-mansfield-2022.jpg">
<meta name="twitter:image:alt" content="Rod Stewart Extends 2022 Tour Dates: Ticket Presale Code &amp; On-Sale Info | Zumic | Music News, Tour Dates, Ticket Presale Info, and More">
<meta property="article:section" content="Concert Announcements">
<meta property="article:published_time" content="2022-02-18T11:42:04-05:00">
<meta property="article:publisher" content="https://www.facebook.com/zumicnews">
<meta property="article:modified_time" content="2022-02-19T06:37:29-05:00">
<meta property="article:tag" content="Pop Rock">
<meta property="article:tag" content="Classic Rock">
<meta property="article:tag" content="Singer-Songwriter">
<meta property="article:tag" content="Rod Stewart">
<meta property="news_keywords" content="pop rock, classic rock, singer-songwriter, rod stewart, music, tickets, presale, entertainment, arts, tv, celebrities, lifestyle, culture">
<link rel="canonical" href="https://zumic.com/rod-stewart-extends-2022-tour-dates-ticket-presale-code-and-on-sale-info">
<link rel="dns-prefetch" href="//s.w.org">
<link rel="amphtml" href="https://zumic.com/rod-stewart-extends-2022-tour-dates-ticket-presale-code-and-on-sale-info/amp">
<script type="application/ld+json">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</script>
</head>
<body>


<div id="page-wrapper" class="page-wrapper homepage-wrap">

<header id="header" class="wrapper header fixed ">
<div class="header-top">
<div class="container">
<a href="https://zumic.com" class="logo">
<img class="lazy" data-src="/assets/img/logo.png" data-srcset="/assets/img/logo.png" alt="Zumic">
<img class="lazy" data-src="/assets/img/s-logo.png" data-srcset="/assets/img/s-logo.png" alt="Zumic">
</a>
<a class="header-top-menu-trigger js-header-top-menu-trigger">
<i class="icon-menulines"></i>
<i class="icon-mcross"></i>
</a>
<div class="header-top-menu">
<ul>
<li>
<a href="https://zumic.com/explore">Explore</a>
</li>
<li class="nested">
<a href="https://zumic.com/local-events">Local concerts</a>
<span class="nested-trigger"></span>
 <ul>
<li>
<a href="https://zumic.com/local-events/new-additions">New Additions</a>
</li>
<li>
<a href="https://zumic.com/local-events/popular">Popular</a>
</li>
</ul>
</li>
<li class="nested">
<a href="https://zumic.com/new-music">New music</a>
<span class="nested-trigger"></span>
<ul>
<li>
<a href="https://zumic.com/new-music">New Additions</a>
</li>
<li>
<a href="https://zumic.com/new-music/popular">Popular</a>
</li>
</ul>
</li>
</ul>
</div>
<a id="login-btn" href="https://zumic.com/account/login" class="header-login button mod-login">Login/Register</a>
<div class="header-search" data-module="search-form">
<div class="header-search-trigger">
<i class="icon-lup"></i>
</div>
<form action="https://zumic.com/search" method="get">

<input class="header-search-txt" type="text" name="query" placeholder="Search concerts, music and artists" value="">
<div class="result-search-head-wrap">
<div class="result-search-head"></div>
<div class="result-search-footer">
<a href="#" class="link-view-all">View all results for '<span>alt</span>'</a>
</div>
</div>
<button class="header-search-submit" type="submit">
<i class="icon-lup"></i>
</button>
<span class="header-search-close js-header-search-close">
<img src="/assets/img/cross.png" alt="close search">
</span>
</form>
</div>
</div>
</div>
<div class="header-page-overlay"></div>
</header>

<div id="page-body" class="page-body music-article-wrap tour-article-wrap">
<div class="maincontent">
<div class="topblock">
<div class="img-wrap"></div>
<div class="topblock-inner">
<div class="container">
</div>
</div>
</div>
<div class="mod-topoffset">
<div class="container">
<section class="article">
<div class="row">
<div class="col-xs-12 col-sm-8">
<div class="music-article">
<div class="music-article-top">
<div class="row">
<div class="vbottom col-xs-12 col-sm-12 col-md-12">
<div class="music-article-top-hint">
Tickets
</div>
<h1>Rod Stewart Extends 2022 Tour Dates: Ticket Presale Code &amp; On-Sale Info</h1>
</div>
<div class="vbottom col-xs-12 col-sm-12 col-md-12" style="margin-top: 15px; clear:both;">
<div class="music-article-top-subheader">
Rocking with Cheap Trick this summer in America, plus tours of Australia, New Zealand, the UK, and Ireland
</div>
<div class="stat-item stat-fav" data-module="star_rating" data-button="favorite_article" data-article-id="18255" data-auth="">
</div>
</div>
</div>
<div class="music-article-user">
<div class="row">
<div class="col-xs-12 col-md-6 vcenter">
<span class="user-pic">
<a href="/author/fmarano" rel="nofollow">
<img class="lazy" data-src="https://www.gravatar.com/avatar/a723777af1ba7fd609f86cec1925730f?d=https%3A%2F%2Fzumic.com%2Fassets%2Fimg%2Fzumic-square.png&amp;s=200" alt="Francesco Marano">
</a>
</span>
<div class="user-txt">
<h3>
<a href="/author/fmarano">
by Francesco Marano
</a>
</h3>
<h5>
Published February 18, 2022
</h5>
</div>
</div>
<div class="col-xs-12 col-md-6 vcenter">
<div class="user-soc">
<div data-module="sharing-socials">
<div id="share" class="social-likes" data-counters="no">
<div title="Share link on Facebook" class="soclink facebook">
<i class="icon-facebook"></i>
</div>
<div title="Share link on Twitter" class="soclink twitter">
<i class="icon-twitter"></i>
</div>
<a class="soclink" href="https://zumic.com/account/login" id="share-with-email" title="Share with email">
<i class="icon-mail"></i>
</a>
</div>
 <div class="remodal feedback-modal" data-remodal-id="share-with-email-modal">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="area-heading">
<div class="area-heading-title">
Share
</div>
</div>
<form id="share-form" name="shareform" action="https://zumic.com/send-email">
<div class="share-modal-txt "></div>
<div class="input-row">
<div class="input-row el-contact-form ">
<input type="text" name="sender_name" placeholder="Type your name" value="">
</div>
</div>
<div class="input-row" style="display: none">
<div class="input-row el-contact-form">
<input type="text" name="sender_email" placeholder="Type your email*" value="">
</div>
</div>
<div class="input-row">
<div class="input-row el-contact-form ">
<input type="text" name="recipient" placeholder="Type recipient email*" value="">
</div>
</div>
<textarea name="user_message" placeholder="Add a message to send with this article"></textarea>
<input type="hidden" name="reference" value="https://zumic.com/rod-stewart-extends-2022-tour-dates-ticket-presale-code-and-on-sale-info">
<div class="modal-btns">


<input type="submit" value="Send" class="button mod-modal-ok">
</div>
</form>
</div>

</div>
</div>
</div>
</div>
</div>
</div>
<div class="article-content">
<div class="music-article-maincontent ctext">
<p style="text-align:center"><img alt="" height="350" src="/wp-content/uploads/2021/10/rod-stewart-cheap-trick-xfinity-center-mansfield-2022.jpg" width="622" /></p>
<p>This summer, classic rock legends Rod Stewart and Cheap Trick will be touring North America together.</p>
<p>In March, Rod heads out on a tour through Australia and New Zealand before returning to the states in May for a Las Vegas residency. This summer, Rod will team up with Cheap Trick for a summer trek through the USA and Canada from June into September. After another brief run of headlining Las Vegas shows in September and October, Rod returns to the UK and Ireland in November.</p>
<h5>When do Rod Stewart 2022 tour tickets go on sale and what is the presale code?</h5>
<p>Tickets for the previously announced shows are now on sale. For the new dates, the general public on-sale begins as early as February 25. Presales for Rod Stewart VIP packages and fan club members begin February 21. Cheap Trick VIP packages / fan club members, Citi cardholders, Live Nation, LN Mobile App, and local venues/radio presales will follow. Keep in mind, each date is different and details are subject to change.</p>
<p>For the Citi presale, you can use the promo passcode<strong> 412800</strong>,<strong> </strong>but you will need the card to complete your purchase. The Live Nation presale password is <strong>CURTAIN</strong>, and the LN Mobile App code is <strong>COVERT</strong>. Click through the individual concert links for more information about the show you&#39;re interested in.</p>
<p>For the health and safety of all, please make sure to get <a href="https://www.vaccines.gov/" target="_blank">fully vaccinated</a> and follow your local guidance about health and safety precautions. The newer variants are more contagious than previous strains of COVID, and booster shots are now recommended for everyone who has been vaccinated for over five months.</p>
<div class="concerts-closest">
<h2>Rod Stewart Tour Dates and Tickets Near You</h2>
<div class="consert-area mod-ticket">
<div class="consert-area-row">
<div class="ticket-date">
Aug 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022">
Rod Stewart and Cheap Trick at PNC Bank Arts Center
</a>
</div>
<div class="event-item-descr-loc">
<span>PNC Bank Arts Center</span>
Holmdel, NJ
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 23
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022">
Rod Stewart and Cheap Trick at Northwell Health at Jones Beach Theater
</a>
</div>
<div class="event-item-descr-loc">
<span>Northwell Health at Jones Beach Theater</span>
Wantagh, NY
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
</div> </div>
<h2>Rod Stewart All Tour Dates and Tickets</h2>
<div class="consert-area mod-ticket">
<div class="consert-area-row">
<div class="ticket-date">
Mar 12
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-sandalford-estate-swan-valley-in-caversham-wa-on-mar-12-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-sandalford-estate-swan-valley-in-caversham-wa-on-mar-12-2022">
Rod Stewart at Sandalford Estate Swan Valley
</a>
</div>
<div class="event-item-descr-loc">
<span>Sandalford Estate Swan Valley</span>
Caversham, WA, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-sandalford-estate-swan-valley-in-caversham-wa-on-mar-12-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 15
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-rod-laver-arena-in-melbourne-victoria-on-mar-15-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-rod-laver-arena-in-melbourne-victoria-on-mar-15-2022">
Rod Stewart at Rod Laver Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Rod Laver Arena</span>
Melbourne, Victoria, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-rod-laver-arena-in-melbourne-victoria-on-mar-15-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-rod-laver-arena-in-melbourne-victoria-on-mar-16-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-rod-laver-arena-in-melbourne-victoria-on-mar-16-2022">
Rod Stewart at Rod Laver Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Rod Laver Arena</span>
Melbourne, Victoria, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-rod-laver-arena-in-melbourne-victoria-on-mar-16-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 19
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-mt-duneed-estate-in-waurn-ponds-vic-on-mar-19-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-mt-duneed-estate-in-waurn-ponds-vic-on-mar-19-2022">
Rod Stewart at Mt Duneed Estate
</a>
</div>
<div class="event-item-descr-loc">
<span>Mt Duneed Estate</span>
Waurn Ponds, VIC, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-mt-duneed-estate-in-waurn-ponds-vic-on-mar-19-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 26
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-roche-estate-in-pokolbin-on-mar-26-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-roche-estate-in-pokolbin-on-mar-26-2022">
Rod Stewart at Roche Estate
</a>
</div>
<div class="event-item-descr-loc">
<span>Roche Estate</span>
Pokolbin, NSW, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-roche-estate-in-pokolbin-on-mar-26-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 27
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-centennial-vineyards-in-bowral-nsw-on-mar-27-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-centennial-vineyards-in-bowral-nsw-on-mar-27-2022">
Rod Stewart at Centennial Vineyards
</a>
</div>
<div class="event-item-descr-loc">
<span>Centennial Vineyards</span>
Bowral, NSW, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-centennial-vineyards-in-bowral-nsw-on-mar-27-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
 buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 30
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-qudos-bank-arena-in-sydney-olympic-park-nsw-on-mar-30-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-qudos-bank-arena-in-sydney-olympic-park-nsw-on-mar-30-2022">
Rod Stewart at Qudos Bank Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Qudos Bank Arena</span>
Sydney Olympic Park, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-qudos-bank-arena-in-sydney-olympic-park-nsw-on-mar-30-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 2
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-sirromet-winery-in-mount-cotton-qld-on-apr-2-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-sirromet-winery-in-mount-cotton-qld-on-apr-2-2022">
Rod Stewart at Sirromet Winery
</a>
</div>
<div class="event-item-descr-loc">
<span>Sirromet Winery</span>
Mount Cotton, QLD, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-sirromet-winery-in-mount-cotton-qld-on-apr-2-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 3
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-sirromet-winery-in-mount-cotton-qld-on-apr-3-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-sirromet-winery-in-mount-cotton-qld-on-apr-3-2022">
Rod Stewart at Sirromet Winery
</a>
</div>
<div class="event-item-descr-loc">
<span>Sirromet Winery</span>
Mount Cotton, QLD, Australia
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-sirromet-winery-in-mount-cotton-qld-on-apr-3-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 6
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-forsyth-barr-stadium-in-dunedin-on-apr-06-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-forsyth-barr-stadium-in-dunedin-on-apr-06-2022">
Rod Stewart at Forsyth Barr Stadium
</a>
</div>
<div class="event-item-descr-loc">
<span>Forsyth Barr Stadium</span>
Dunedin, Otago, New Zealand
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-forsyth-barr-stadium-in-dunedin-on-apr-06-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 9
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-mission-estate-winery-in-napier-on-apr-09-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-mission-estate-winery-in-napier-on-apr-09-2022">
Rod Stewart at Mission Estate Winery
</a>
</div>
<div class="event-item-descr-loc">
<span>Mission Estate Winery</span>
Napier, New Zealand
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-mission-estate-winery-in-napier-on-apr-09-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 10
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-mission-estate-winery-in-napier-on-apr-10-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-mission-estate-winery-in-napier-on-apr-10-2022">
Rod Stewart at Mission Estate Winery
</a>
</div>
<div class="event-item-descr-loc">
<span>Mission Estate Winery</span>
Napier, New Zealand
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-mission-estate-winery-in-napier-on-apr-10-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
May 13
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-13-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-13-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-13-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
May 14
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-14-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-14-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-14-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
May 18
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-18-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-18-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-18-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
May 20
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-20-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-20-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-20-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
May 21
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-21-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-21-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-may-21-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 10
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-rogers-arena-in-vancouver-on-jun-10-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-rogers-arena-in-vancouver-on-jun-10-2022">
Rod Stewart and Cheap Trick at Rogers Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Rogers Arena</span>
Vancouver, BC, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-rogers-arena-in-vancouver-on-jun-10-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 11
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-climate-pledge-arena-in-seattle-on-jun-11-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-climate-pledge-arena-in-seattle-on-jun-11-2022">
Rod Stewart and Cheap Trick at Climate Pledge Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Climate Pledge Arena</span>
Seattle, WA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-climate-pledge-arena-in-seattle-on-jun-11-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 14
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-hollywood-bowl-in-hollywood-on-jun-14-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-hollywood-bowl-in-hollywood-on-jun-14-2022">
Rod Stewart and Cheap Trick at Hollywood Bowl
</a>
</div>
<div class="event-item-descr-loc">
<span>Hollywood Bowl</span>
Los Angeles, CA
 </div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-hollywood-bowl-in-hollywood-on-jun-14-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 17
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-shoreline-amphitheatre-in-mountain-view-on-jun-17-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-shoreline-amphitheatre-in-mountain-view-on-jun-17-2022">
Rod Stewart and Cheap Trick at Shoreline Amphitheatre
</a>
</div>
<div class="event-item-descr-loc">
<span>Shoreline Amphitheatre</span>
Mountain View, CA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-shoreline-amphitheatre-in-mountain-view-on-jun-17-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 18
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-santa-barbara-bowl-in-santa-barbara-on-jun-18-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-santa-barbara-bowl-in-santa-barbara-on-jun-18-2022">
Rod Stewart and Cheap Trick at Santa Barbara Bowl
</a>
</div>
<div class="event-item-descr-loc">
<span>Santa Barbara Bowl</span>
Santa Barbara, CA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-santa-barbara-bowl-in-santa-barbara-on-jun-18-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 21
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-north-island-credit-union-amphitheatre-in-chula-vista-on-jun-21-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-north-island-credit-union-amphitheatre-in-chula-vista-on-jun-21-2022">
Rod Stewart and Cheap Trick at North Island Credit Union Amphitheatre
</a>
</div>
<div class="event-item-descr-loc">
<span>North Island Credit Union Amphitheatre</span>
Chula Vista, CA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-north-island-credit-union-amphitheatre-in-chula-vista-on-jun-21-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 24
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-footprint-center-in-phoenix-on-jun-24-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-footprint-center-in-phoenix-on-jun-24-2022">
Rod Stewart and Cheap Trick at Footprint Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Footprint Center</span>
Phoenix, AZ
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-footprint-center-in-phoenix-on-jun-24-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jun 26
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-ball-arena-in-denver-on-jun-26-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-ball-arena-in-denver-on-jun-26-2022">
Rod Stewart and Cheap Trick at Ball Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Ball Arena</span>
Denver, CO
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-ball-arena-in-denver-on-jun-26-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 1
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-dickies-arena-in-fort-worth-on-jul-01-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-dickies-arena-in-fort-worth-on-jul-01-2022">
Rod Stewart and Cheap Trick at Dickies Arena - Fort Worth
</a>
</div>
<div class="event-item-descr-loc">
<span>Dickies Arena - Fort Worth</span>
Fort Worth, TX
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-dickies-arena-in-fort-worth-on-jul-01-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 2
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-the-cynthia-woods-mitchell-pavilion-in-spring-on-jul-02-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-the-cynthia-woods-mitchell-pavilion-in-spring-on-jul-02-2022">
Rod Stewart and Cheap Trick at The Cynthia Woods Mitchell Pavilion
</a>
</div>
<div class="event-item-descr-loc">
<span>The Cynthia Woods Mitchell Pavilion</span>
The Woodlands, TX
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-the-cynthia-woods-mitchell-pavilion-in-spring-on-jul-02-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 5
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-bridgestone-arena-in-nashville-on-jul-05-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-bridgestone-arena-in-nashville-on-jul-05-2022">
Rod Stewart and Cheap Trick at Bridgestone Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Bridgestone Arena</span>
Nashville, TN
</div>
</div>
 </div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-bridgestone-arena-in-nashville-on-jul-05-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 7
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-american-family-insurance-amphitheater-summerfest-in-milwaukee-on-jul-07-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-american-family-insurance-amphitheater-summerfest-in-milwaukee-on-jul-07-2022">
Rod Stewart and Cheap Trick at American Family Insurance Amphitheater
</a>
</div>
<div class="event-item-descr-loc">
<span>American Family Insurance Amphitheater</span>
Milwaukee, WI
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-american-family-insurance-amphitheater-summerfest-in-milwaukee-on-jul-07-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 8
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-xcel-energy-center-in-saint-paul-on-jul-08-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-xcel-energy-center-in-saint-paul-on-jul-08-2022">
Rod Stewart and Cheap Trick at Xcel Energy Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Xcel Energy Center</span>
Saint Paul, MN
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-xcel-energy-center-in-saint-paul-on-jul-08-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 12
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-riverbend-music-center-in-cincinnati-oh-on-jul-12-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-riverbend-music-center-in-cincinnati-oh-on-jul-12-2022">
Rod Stewart and Cheap Trick at Riverbend Music Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Riverbend Music Center</span>
Cincinnati, OH
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-riverbend-music-center-in-cincinnati-oh-on-jul-12-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 15
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-ruoff-home-mortgage-music-center-in-noblesville-on-jul-15-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-ruoff-home-mortgage-music-center-in-noblesville-on-jul-15-2022">
Rod Stewart and Cheap Trick at Ruoff Home Mortgage Music Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Ruoff Home Mortgage Music Center</span>
Noblesville, IN
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-ruoff-home-mortgage-music-center-in-noblesville-on-jul-15-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-hollywood-casino-amphitheatre-tinley-park-in-tinley-park-on-jul-16-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-hollywood-casino-amphitheatre-tinley-park-in-tinley-park-on-jul-16-2022">
Rod Stewart and Cheap Trick at Hollywood Casino Amphitheatre - Tinley Park
</a>
</div>
<div class="event-item-descr-loc">
<span>Hollywood Casino Amphitheatre - Tinley Park</span>
Tinley Park, IL
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-hollywood-casino-amphitheatre-tinley-park-in-tinley-park-on-jul-16-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
 </div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 19
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-blossom-music-center-in-cuyahoga-falls-on-jul-19-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-blossom-music-center-in-cuyahoga-falls-on-jul-19-2022">
Rod Stewart and Cheap Trick at Blossom Music Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Blossom Music Center</span>
Cuyahoga Falls, OH
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-blossom-music-center-in-cuyahoga-falls-on-jul-19-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 22
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-saratoga-performing-arts-center-in-saratoga-springs-on-jul-22-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-saratoga-performing-arts-center-in-saratoga-springs-on-jul-22-2022">
Rod Stewart and Cheap Trick at Saratoga Springs Performing Arts Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Saratoga Springs Performing Arts Center</span>
Saratoga Springs, NY
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-saratoga-performing-arts-center-in-saratoga-springs-on-jul-22-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 23
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-budweiser-gardens-in-london-on-jul-23-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-budweiser-gardens-in-london-on-jul-23-2022">
Rod Stewart and Cheap Trick at Budweiser Gardens
 </a>
</div>
<div class="event-item-descr-loc">
<span>Budweiser Gardens</span>
London, Ontario, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-budweiser-gardens-in-london-on-jul-23-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 26
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-budweiser-stage-toronto-in-toronto-on-jul-26-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-budweiser-stage-toronto-in-toronto-on-jul-26-2022">
Rod Stewart and Cheap Trick at Budweiser Stage
</a>
</div>
<div class="event-item-descr-loc">
<span>Budweiser Stage</span>
Toronto, ON, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-budweiser-stage-toronto-in-toronto-on-jul-26-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Jul 27
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-dte-energy-music-theatre-in-clarkston-on-jul-27-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-dte-energy-music-theatre-in-clarkston-on-jul-27-2022">
Rod Stewart and Cheap Trick at DTE Energy Music Theatre
</a>
</div>
<div class="event-item-descr-loc">
<span>DTE Energy Music Theatre</span>
Clarkston, MI
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-dte-energy-music-theatre-in-clarkston-on-jul-27-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 12
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-xfinity-center-ma-in-mansfield-on-aug-12-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-xfinity-center-ma-in-mansfield-on-aug-12-2022">
Rod Stewart and Cheap Trick at Xfinity Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Xfinity Center</span>
Mansfield, MA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-xfinity-center-ma-in-mansfield-on-aug-12-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 13
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-mohegan-sun-arena-in-uncasville-on-aug-13-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-mohegan-sun-arena-in-uncasville-on-aug-13-2022">
Rod Stewart and Cheap Trick at Mohegan Sun Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Mohegan Sun Arena</span>
Uncasville, CT
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-mohegan-sun-arena-in-uncasville-on-aug-13-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022">
Rod Stewart and Cheap Trick at PNC Bank Arts Center
</a>
</div>
<div class="event-item-descr-loc">
<span>PNC Bank Arts Center</span>
Holmdel, NJ
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 19
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-mark-g-etess-arena-at-hard-rock-hotel-casino-in-atlantic-city-on-aug-19-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-mark-g-etess-arena-at-hard-rock-hotel-casino-in-atlantic-city-on-aug-19-2022">
Rod Stewart and Cheap Trick at Mark G Etess at Hard Rock Hotel and Casino
</a>
</div>
<div class="event-item-descr-loc">
<span>Mark G Etess at Hard Rock Hotel and Casino</span>
Atlantic City, NJ
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-mark-g-etess-arena-at-hard-rock-hotel-casino-in-atlantic-city-on-aug-19-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 20
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-hersheypark-stadium-in-hershey-on-aug-20-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-hersheypark-stadium-in-hershey-on-aug-20-2022">
Rod Stewart and Cheap Trick at Hersheypark Stadium
</a>
</div>
<div class="event-item-descr-loc">
<span>Hersheypark Stadium</span>
Hershey, PA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-hersheypark-stadium-in-hershey-on-aug-20-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 23
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022">
Rod Stewart and Cheap Trick at Northwell Health at Jones Beach Theater
</a>
</div>
<div class="event-item-descr-loc">
<span>Northwell Health at Jones Beach Theater</span>
Wantagh, NY
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 26
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-pnc-music-pavilion-charlotte-in-charlotte-on-aug-26-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-pnc-music-pavilion-charlotte-in-charlotte-on-aug-26-2022">
Rod Stewart and Cheap Trick at PNC Music Pavilion
</a>
</div>
<div class="event-item-descr-loc">
<span>PNC Music Pavilion</span>
Charlotte, NC
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-pnc-music-pavilion-charlotte-in-charlotte-on-aug-26-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 27
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-merriweather-post-pavilion-in-columbia-on-aug-27-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-merriweather-post-pavilion-in-columbia-on-aug-27-2022">
Rod Stewart and Cheap Trick at Merriweather Post Pavilion
</a>
</div>
<div class="event-item-descr-loc">
<span>Merriweather Post Pavilion</span>
Columbia, MD
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-merriweather-post-pavilion-in-columbia-on-aug-27-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Aug 31
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-ameris-bank-amphitheatre-in-alpharetta-on-aug-31-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-ameris-bank-amphitheatre-in-alpharetta-on-aug-31-2022">
Rod Stewart and Cheap Trick at Ameris Bank Amphitheatre
</a>
</div>
<div class="event-item-descr-loc">
<span>Ameris Bank Amphitheatre</span>
Alpharetta, GA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-ameris-bank-amphitheatre-in-alpharetta-on-aug-31-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 2
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-dailys-place-amphitheater-in-jacksonville-on-sep-02-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-dailys-place-amphitheater-in-jacksonville-on-sep-02-2022">
Rod Stewart and Cheap Trick at Daily&#039;s Place
</a>
</div>
<div class="event-item-descr-loc">
<span>Daily&#039;s Place</span>
Jacksonville, FL
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-dailys-place-amphitheater-in-jacksonville-on-sep-02-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 3
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-and-cheap-trick-at-amalie-arena-in-tampa-on-sep-03-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-and-cheap-trick-at-amalie-arena-in-tampa-on-sep-03-2022">
Rod Stewart and Cheap Trick at Amalie Arena
</a>
</div>
<div class="event-item-descr-loc">
 <span>Amalie Arena</span>
Tampa, FL
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-and-cheap-trick-at-amalie-arena-in-tampa-on-sep-03-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 7
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-ppg-paints-arena-in-pittsburgh-on-sep-07-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-ppg-paints-arena-in-pittsburgh-on-sep-07-2022">
Rod Stewart and Cheap Trick at PPG Paints Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>PPG Paints Arena</span>
Pittsburgh, PA
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-ppg-paints-arena-in-pittsburgh-on-sep-07-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 9
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-bell-centre-in-montreal-on-sep-09-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-bell-centre-in-montreal-on-sep-09-2022">
Rod Stewart and Cheap Trick at Centre Bell
</a>
</div>
<div class="event-item-descr-loc">
<span>Centre Bell</span>
Montréal, QC, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-bell-centre-in-montreal-on-sep-09-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 10
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-canadian-tire-centre-in-kanata-on-sep-10-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-canadian-tire-centre-in-kanata-on-sep-10-2022">
Rod Stewart and Cheap Trick at Canadian Tire Centre
</a>
</div>
<div class="event-item-descr-loc">
<span>Canadian Tire Centre</span>
Ottawa, Ontario, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-canadian-tire-centre-in-kanata-on-sep-10-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 14
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-sasktel-centre-in-saskatoon-on-sep-14-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-sasktel-centre-in-saskatoon-on-sep-14-2022">
Rod Stewart and Cheap Trick at SaskTel Centre
</a>
</div>
<div class="event-item-descr-loc">
<span>SaskTel Centre</span>
Saskatoon, SK, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-sasktel-centre-in-saskatoon-on-sep-14-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-scotiabank-saddledome-in-calgary-on-sep-16-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-scotiabank-saddledome-in-calgary-on-sep-16-2022">
Rod Stewart and Cheap Trick at Scotiabank Saddledome
</a>
</div>
<div class="event-item-descr-loc">
<span>Scotiabank Saddledome</span>
Calgary, AB, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-scotiabank-saddledome-in-calgary-on-sep-16-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 17
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-rogers-place-in-edmonton-on-sep-17-2022">
Rod Stewart and Cheap Trick
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-rogers-place-in-edmonton-on-sep-17-2022">
Rod Stewart and Cheap Trick at Rogers Place
</a>
</div>
<div class="event-item-descr-loc">
<span>Rogers Place</span>
Edmonton, AB, Canada
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-rogers-place-in-edmonton-on-sep-17-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 23
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-23-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-23-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-23-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 24
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-24-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-24-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-24-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 28
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-28-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-28-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-28-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Sep 30
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-30-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-30-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-sep-30-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Oct 1
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-oct-01-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-oct-01-2022">
Rod Stewart at Caesars Palace
</a>
</div>
<div class="event-item-descr-loc">
<span>Caesars Palace</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-colosseum-at-caesars-palace-in-las-vegas-on-oct-01-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Nov 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-motorpoint-arena-nottingham-in-nottingham-england-on-nov-16-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-motorpoint-arena-nottingham-in-nottingham-england-on-nov-16-2022">
Rod Stewart at Motorpoint Arena Nottingham
</a>
</div>
<div class="event-item-descr-loc">
<span>Motorpoint Arena Nottingham</span>
Nottingham, England, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-motorpoint-arena-nottingham-in-nottingham-england-on-nov-16-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
 buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Nov 18
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-3arena-in-dublin-county-dublin-on-nov-18-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-3arena-in-dublin-county-dublin-on-nov-18-2022">
Rod Stewart at 3Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>3Arena</span>
Dublin, County Dublin, Ireland
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-3arena-in-dublin-county-dublin-on-nov-18-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Nov 19
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-3arena-in-dublin-on-nov-19-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-3arena-in-dublin-on-nov-19-2022">
Rod Stewart at 3Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>3Arena</span>
Dublin, County Dublin, Ireland
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-3arena-in-dublin-on-nov-19-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Nov 22
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-o2-arena-london-in-london-england-on-nov-22-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-o2-arena-london-in-london-england-on-nov-22-2022">
Rod Stewart at O2 Arena - London
</a>
</div>
<div class="event-item-descr-loc">
<span>O2 Arena - London</span>
London, England, United Kingdom
</div>
 </div>
</div>
<div>
<a href="/events/rod-stewart-at-o2-arena-london-in-london-england-on-nov-22-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Nov 29
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-ovo-hydro-in-glasgow-scotland-on-nov-29-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-ovo-hydro-in-glasgow-scotland-on-nov-29-2022">
Rod Stewart at OVO Hydro
</a>
</div>
<div class="event-item-descr-loc">
<span>OVO Hydro</span>
Glasgow, Scotland, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-ovo-hydro-in-glasgow-scotland-on-nov-29-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Dec 6
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-mands-bank-arena-in-port-of-liverpool-england-on-dec-6-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-mands-bank-arena-in-port-of-liverpool-england-on-dec-6-2022">
Rod Stewart at M&amp;S Bank Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>M&amp;S Bank Arena</span>
Port of Liverpool, England, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-mands-bank-arena-in-port-of-liverpool-england-on-dec-6-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Dec 9
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-utilita-arena-birmingham-in-birmingham-england-on-dec-9-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-utilita-arena-birmingham-in-birmingham-england-on-dec-9-2022">
 Rod Stewart at Utilita Arena Birmingham
</a>
</div>
<div class="event-item-descr-loc">
<span>Utilita Arena Birmingham</span>
Birmingham, England, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-utilita-arena-birmingham-in-birmingham-england-on-dec-9-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Dec 13
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-first-direct-arena-in-leeds-england-on-dec-13-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-first-direct-arena-in-leeds-england-on-dec-13-2022">
Rod Stewart at First Direct Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>First Direct Arena</span>
Leeds, England, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-first-direct-arena-in-leeds-england-on-dec-13-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Dec 14
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-ao-arena-in-manchester-england-on-dec-14-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-ao-arena-in-manchester-england-on-dec-14-2022">
Rod Stewart at AO Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>AO Arena</span>
Manchester, England, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-ao-arena-in-manchester-england-on-dec-14-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Dec 17
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-utilita-arena-newcastle-in-newcastle-upon-tyne-england-on-dec-17-2022">
Rod Stewart
 </a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-utilita-arena-newcastle-in-newcastle-upon-tyne-england-on-dec-17-2022">
Rod Stewart at Utilita Arena Newcastle
</a>
</div>
<div class="event-item-descr-loc">
<span>Utilita Arena Newcastle</span>
Newcastle upon Tyne, England, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-utilita-arena-newcastle-in-newcastle-upon-tyne-england-on-dec-17-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Dec 20
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/rod-stewart-at-the-sse-arena-in-belfast-northern-ireland-on-dec-20-2022">
Rod Stewart
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/rod-stewart-at-the-sse-arena-in-belfast-northern-ireland-on-dec-20-2022">
Rod Stewart at The SSE Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>The SSE Arena</span>
Belfast, Northern Ireland, United Kingdom
</div>
</div>
</div>
<div>
<a href="/events/rod-stewart-at-the-sse-arena-in-belfast-northern-ireland-on-dec-20-2022" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
</div>
<p>We recommend following Rod Stewart on his social media accounts and signing up for <a href="http://www.rodstewart.com/" target="_blank">his free email newsletter</a> (bottom right of page), in addition to checking your local venue&#39;s social media and email subscription, to get the most up-to-date information.</p>
<p>For more, check out <a href="https://zumic.com/artists/rod-stewart/music">Rod Stewart&#39;s Zumic artist page</a>.</p>
</div>
</div>
<div class="music-article-bottom">
<div class="music-article-bottom-stats">
<div class="stat-item stat-upwote item-bottom-stats" data-rating="18255" title="upvotes">
<a href="https://zumic.com/article-vote/18255" class="ico article-vote">
<i class="icon-upwote"></i>
</a>
<span class="votes">
2
</span>
</div>
<div class="stat-item stat-views" title="views">
<span class="ico">
 <i class="icon-eye"></i>
</span>
<span>
134
</span>
</div>
</div>
<div class="music-article-bottom-tags">
<div class="tag-caption area-heading">
<span class="area-heading-title">artists</span>
</div>
<a href="/artists/rod-stewart" class="tag">Rod Stewart</a>
<div class="tag-caption area-heading">
<span class="area-heading-title">genres</span>
</div>
<a href="/genres/rock/classic-rock" class="tag">
Classic Rock
</a>
<a href="/genres/rock/pop-rock" class="tag">
Pop Rock
</a>
<a href="/genres/miscellaneous/singer-songwriter" class="tag">
Singer-Songwriter
</a>
</div>
</div>

<div class="comments">
<div class="comments-top">
<div class="area-heading">
<div class="area-heading-title">
сomments
</div>
<div class="area-heading-btn">
<label>
See an error?
</label>
<span data-module="feedback-front">
<a href="https://zumic.com/account/login" id="leave-feedback-button" class="el-button mod-shadow min-160">
<span>Send Feedback</span>
</a>
</span>
</div>
</div>
</div>

<div data-module="disqus" data-key="zumic">
<div class="disqus-comments">
<div id='disqus_thread'></div>
</div>
</div>
</div>
</div>
</div>


<div class="sidebar col-xs-12 col-sm-4">
<div class="el-sidebar-poster">
</div>

<div class="events-results">

<div class="named-event">
<div class="named-event-top">
<a href="/artists/rod-stewart">
<div class="named-event-top-pic">
<img class="lazy" data-src="/wp-content/uploads/2015/06/rod-stewart-tour-dates-music-news.jpg" alt="image for artist Rod Stewart">
</div>
<div class="named-event-top-name">
 Rod Stewart
</div>
</a>
</div>
<div class="event-item row">
<div class="event-item-left col-xs-3 col-sm-12 col-md-3  ">
<div class="event-item-left-m">
Aug
</div>
<div class="event-item-left-d">
16
</div>
</div>
<div class="event-item-right col-xs-9 col-sm-12 col-md-9">
<a href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022" class="event-item-title">
Rod Stewart and Cheap Trick
</a>
<div class="event-item-descr">
<a href="/events/rod-stewart-and-cheap-trick-at-pnc-bank-arts-center-in-holmdel-on-aug-16-2022">
<span class="event-item-descr-place">
PNC Bank Arts Center
</span>
<span class="event-item-descr-loc">
Holmdel, NJ
</span>
</a>
</div>
</div>
</div>
<div class="event-item row">
<div class="event-item-left col-xs-3 col-sm-12 col-md-3  ">
<div class="event-item-left-m">
Aug
</div>
<div class="event-item-left-d">
23
</div>
</div>
<div class="event-item-right col-xs-9 col-sm-12 col-md-9">
<a href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022" class="event-item-title">
Rod Stewart and Cheap Trick
</a>
<div class="event-item-descr">
<a href="/events/rod-stewart-and-cheap-trick-at-northwell-health-at-jones-beach-theater-in-wantagh-on-aug-23-2022">
<span class="event-item-descr-place">
Northwell Health at Jones Beach Theater
</span>
<span class="event-item-descr-loc">
Wantagh, NY
</span>
</a>
</div>
</div>
</div>
</div>
</div>
<div class="named-event sponsors-links">
<div class="named-event-top">
<div class="named-event-top-name text-center">
Powered By
</div>
</div>
<div class="row text-center">
<a href="http://ticketmaster.evyy.net/c/253533/264167/4272" target="_blank">
<img class="lazy" data-src="/assets/img/p1.png" alt="image for ticketmaster">
</a>
<a href="https://shareasale.com/r.cfm?b=1128188&amp;u=701549&amp;m=76847&amp;urllink=https%3A%2F%2Fwww.scorebig.com" target="_blank">
<img class="lazy" data-src="/thumbs/wp-content/uploads/scorebig-tickets-info_200x80.png" alt="image for ticketnetwork">
</a>
<a href="https://ticketnetwork.7eer.net/c/231399/120057/2322" target="_blank">
<img class="lazy" data-src="/assets/img/p3.png" alt="image for ticketnetwork">
</a>
<a href="https://prf.hn/click/camref:1101la8u4/destination:https%3A%2F%2Fwww.stubhub.com" target="_blank">
<img class="lazy" data-src="/assets/img/p4.png" alt="image for stubhub">
</a>
</div>
</div>
<div class="el-sidebar-poster">
</div>

</div> 
</div>
</section>
</div>
<div class="article-detail-recomended">
<div class="container">
<div class="area-heading">
<div class="area-heading-title">
recommended music
</div>
</div>
<div class="maincontent-inner-list row">

<div class="item  col-xs-12 col-sm-4 ">
<div class="item-inner">
<span class="item-mark">
<i class="icon-z-mark"></i>
</span>
<a href="/rod-stewart-adds-2021-las-vegas-residency-dates-ticket-presale-code-and-on-sale-info" class="article-img-container">
<div class="article-img-background lazy " data-bg="url(/thumbs/wp-content/uploads/rod-stewart-2021-las-vegas-dates-tickets_x300.jpg)">
</div>
<img class="article-img lazy" data-src="/thumbs/wp-content/uploads/rod-stewart-2021-las-vegas-dates-tickets_x300.jpg" alt="image for article Rod Stewart Adds 2021 Las Vegas Dates: Ticket Presale Code &amp; On-Sale Info">
</a>
<div class="item-mid">
<div class="item-date">
June 17, 2021
</div>
<div class="item-title">
<a title="Rod Stewart Adds 2021 Las Vegas Dates: Ticket Presale Code &amp; On-Sale Info" href="/rod-stewart-adds-2021-las-vegas-residency-dates-ticket-presale-code-and-on-sale-info">
Rod Stewart Adds 2021 Las Vegas Dates: Ticket Presale Code &amp; On-S...
</a>
</div>
<div class="item-tags">
<a href="/rod-stewart-adds-2021-las-vegas-residency-dates-ticket-presale-code-and-on-sale-info" class="tag active">Tickets</a>
<a href="/genres/rock/classic-rock" class="tag">
Classic Rock
</a>
<a href="/genres/rock/pop-rock" class="tag">
Pop Rock
</a>
<a href="/genres/miscellaneous/singer-songwriter" class="tag">
Singer-Songwriter
</a>
<a href="/artists/rod-stewart" class="tag">
Rod Stewart
</a>
</div>
</div>
<div class="item-bottom">
<div class="item-bottom-stats" data-rating="17683" data-count_rating="https://zumic.com/article-count/17683">
<div class="stat-item stat-upwote" title="upvotes">
<a href="https://zumic.com/account/login" class="ico article-vote">
<i class="icon-upwote"></i>
</a>
<span class="votes">
2
</span>
 </div>
<div class="stat-item stat-views" title="views">
<span class="ico">
<i class="icon-eye"></i>
</span>
<span class="views">
729
</span>
</div>
</div>
</div>
</div>
</div>


<div class="item  col-xs-12 col-sm-4 ">
<div class="item-inner">
<span class="item-mark">
<i class="icon-z-mark"></i>
</span>
<a href="/rod-stewart-and-cheap-trick-plot-2020-tour-dates-ticket-presale-code-and-on-sale-info" class="article-img-container">
<div class="article-img-background lazy " data-bg="url(/thumbs/wp-content/uploads/2019/10/rod-stewart-the-colosseum-at-caesars-palace-las-vegas-2020_x300.jpg)">
</div>
<img class="article-img lazy" data-src="/thumbs/wp-content/uploads/2019/10/rod-stewart-the-colosseum-at-caesars-palace-las-vegas-2020_x300.jpg" alt="image for article Rod Stewart &amp; Cheap Trick Plot 2020 Tour Dates: Ticket Presale Code &amp; On-Sale Info">
</a>
<div class="item-mid">
<div class="item-date">
January 7, 2020
</div>
<div class="item-title">
<a title="Rod Stewart &amp; Cheap Trick Plot 2020 Tour Dates: Ticket Presale Code &amp; On-Sale Info" href="/rod-stewart-and-cheap-trick-plot-2020-tour-dates-ticket-presale-code-and-on-sale-info">
Rod Stewart &amp; Cheap Trick Plot 2020 Tour Dates: Ticket Presale Co...
</a>
</div>
<div class="item-tags">
<a href="/rod-stewart-and-cheap-trick-plot-2020-tour-dates-ticket-presale-code-and-on-sale-info" class="tag active">Tickets</a>
<a href="/genres/rock/classic-rock" class="tag">
Classic Rock
</a>
<a href="/genres/rock/pop-rock" class="tag">
Pop Rock
</a>
<a href="/genres/rock" class="tag">
Rock
</a>
<a href="/artists/cheap-trick" class="tag">
Cheap Trick
</a>
<a href="/artists/rod-stewart" class="tag">
Rod Stewart
</a>
</div>
</div>
<div class="item-bottom">
<div class="item-bottom-stats" data-rating="17000" data-count_rating="https://zumic.com/article-count/17000">
<div class="stat-item stat-upwote" title="upvotes">
<a href="https://zumic.com/account/login" class="ico article-vote">
<i class="icon-upwote"></i>
</a>
<span class="votes">
1
</span>
</div>
<div class="stat-item stat-views" title="views">
<span class="ico">
<i class="icon-eye"></i>
</span>
<span class="views">
1535
</span>
</div>

</div>
</div>
</div>
</div>


<div class="item  col-xs-12 col-sm-4 ">
<div class="item-inner">
<span class="item-mark">
<i class="icon-z-mark"></i>
</span>
<a href="/rod-stewart-adds-2020-las-vegas-residency-dates-ticket-presale-code-and-on-sale-info" class="article-img-container">
<div class="article-img-background lazy " data-bg="url(/thumbs/wp-content/uploads/rod-stewart-las-vegas-dates-tickets-info_x300.jpg)">
</div>
<img class="article-img lazy" data-src="/thumbs/wp-content/uploads/rod-stewart-las-vegas-dates-tickets-info_x300.jpg" alt="image for article Rod Stewart Adds 2020 Las Vegas Residency Dates: Ticket Presale Code &amp; On-Sale Info">
</a>
<div class="item-mid">
<div class="item-date">
October 7, 2019
</div>
<div class="item-title">
<a title="Rod Stewart Adds 2020 Las Vegas Residency Dates: Ticket Presale Code &amp; On-Sale Info" href="/rod-stewart-adds-2020-las-vegas-residency-dates-ticket-presale-code-and-on-sale-info">
Rod Stewart Adds 2020 Las Vegas Residency Dates: Ticket Presale C...
</a>
</div>
<div class="item-tags">
<a href="/rod-stewart-adds-2020-las-vegas-residency-dates-ticket-presale-code-and-on-sale-info" class="tag active">Tickets</a>
<a href="/genres/rock/classic-rock" class="tag">
Classic Rock
</a>
<a href="/genres/rock/pop-rock" class="tag">
Pop Rock
</a>
<a href="/genres/miscellaneous/singer-songwriter" class="tag">
Singer-Songwriter
</a>
<a href="/artists/rod-stewart" class="tag">
Rod Stewart
</a>
</div>
</div>
<div class="item-bottom">
<div class="item-bottom-stats" data-rating="15248" data-count_rating="https://zumic.com/article-count/15248">
<div class="stat-item stat-upwote" title="upvotes">
<a href="https://zumic.com/account/login" class="ico article-vote">
<i class="icon-upwote"></i>
</a>
<span class="votes">
3
</span>
</div>
<div class="stat-item stat-views" title="views">
<span class="ico">
<i class="icon-eye"></i>
</span>
<span class="views">
1181
</span>
</div>
</div>
</div>
</div>
</div>

</div>
</div>
</div>

<div class="text-center optional-button">
<a href="#" class="button el-pointer-btn mod-top">
<span>
Back to top
</span>
<i class="icon-dotarr"></i>
</a>
</div>

</div>
</div>
</div>

<footer id="footer" class="wrapper footer">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-2 footer-logo">
<a class="" href="https://zumic.com">
<img class="lazy" data-src="/assets/img/f-logo.png" data-srcset="/assets/img/f-logo.png" alt="Zumic">
</a>
</div>
<div class="col-xs-12 col-sm-12 col-md-6 footer-nav">
<a href="#" class="footer-nav-control js-footer-nav-control">
QUICK LINKS
<span class="ico-plus"></span>
</a>
<div class="footer-nav-menu">
<div class="row">
<ul>
<li class="col-sm-4 col-md-4 ">
<a href="/who-we-are">Who We Are</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/explore">Explore</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="/jobs">Jobs</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/faq">FAQ</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/local-events">Local Concerts</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/contact-us">Contact Us</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/new-music">New Music</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-xs-12 col-sm-12 col-md-4 footer-form">
<div class="footer-form-title">
Join Our Newsletter<br>
<i>Concerts, Tickets, News & More</i>
</div>
<div data-module="newsletter-form">
<div id="error-block" class="input-row">
<label class="error-label" id="error-message"></label>
</div>
<form name="footer-form-subscr" action="https://zumic.com/subscribe" id="newsletter-form" class="footer-form-subscr">
<div class="input-row">
<input class="footer-form-subscr-txt" name="email" type="text" placeholder="enter your email address">
<button type="submit" class="footer-form-subscr-submit">
</button>
</div>
</form>
</div>
</div>
</div>
</div>
<div class="container">
<div class="footer-bottom">
<div class="row">
<div class="footer-bottom-soc col-xs-12 col-md-4">
<a href="https://www.facebook.com/zumicnews" target="_blank" class="soclink">
<i class="icon-facebook"></i>
</a>
<a href="https://twitter.com/Zumic" target="_blank" class="soclink">
<i class="icon-twitter"></i>
</a>
<a href="https://www.instagram.com/zumicnews/" target="_blank" class="soclink">
<i class="icon-instagram"></i>
</a>
<a href="https://www.youtube.com/user/ZumicTube" target="_blank" class="soclink">
<i class="icon-youtube"></i>
</a>
</div>
<div class="footer-bottom-links col-xs-12 col-md-8">
<ul>
<li>© 2020 Zumic Entertainment, Inc.</li>
 <li>
<a href="/terms-of-service">Terms of Service</a>
</li>
<li>
<a href="/privacy-policy">Privacy Policy</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</footer>
<div class="login-block">
<div class="remodal login-modal" data-remodal-id="login-modal" style="max-width: 814px;">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="area-heading">
<div class="area-heading-title upvote-login">
You must be logged in to <span id="login-modal-title">upvote things</span>.
</div>
</div>
<div class="js-login-tabs login-tabs tabs_default">
<ul class="login-tabs-tabsarea">
<li>
<a class="login-tab" href="#login-1">
<span>LOGIN</span>
</a>
</li>
<li>
<a class="login-tab" href="#login-2">
<span>Register</span>
</a>
</li>
</ul>
<div id="login-1" class="login-content">
<form action="https://zumic.com/account/login" name="login-form" class="login-form submit-js" method="POST">
<input type="hidden" name="_token" value="UHriw1dMSNgpsYDx4D9u9PQAshd4t5yMr1jhx7tg"> <input type="hidden" name="recaptcha" class="recaptcha">
<input type="hidden" name="recaptcha_key" value="6Lfg66IZAAAAANSSvGM9V3aJaPVMOZRq6ZJMy-wK" class="recaptcha_key">
<div>
<div id="error-block" class="input-row">
<label class="error-label" id="error-message"></label>
</div>
<div class="input-row">
<label>
Your Email
</label>
<input id="email-login" required type="email" name="email" placeholder="johnsmith@email.com">
</div>
<div class="input-row mod-pwd">
<label>
Your Password
</label>
<input id="password-login" required type="password" name="password" placeholder="Enter Your Password">
<a class="ico show-pwd" href="#">
<i class="icon-eye"></i>
</a>
</div>
</div>
<a href="https://zumic.com/account/reset_password" class="login-forgot">
Forgot Your Password?
</a>
<div class="input-row text-center btn-input-row">
<button id="btn-login" class="css_spinner cursor_wait el-button mod-shadow mod-md min-330" type="submit">
<span class="active">LOG IN</span>
</button>
</div>
<div class="login-soc">
<div class="login-soc-txt">
or Log In With
</div>
<div class="login-soc-links row">
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-fb" href="https://zumic.com/account/social_login/facebook">
<span><i class="icon-facebook"></i></span>
<span>Facebook</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-gp" href="https://zumic.com/account/social_login/google">
<span><i class="icon-google-p"></i></span>
<span>Google</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-tw" href="https://zumic.com/account/social_login/twitter">
<span><i class="icon-twitter"></i></span>
<span>Twitter</span>
</a>
</div>
</div>
</div>
</form>
</div>
<div id="login-2" class="login-content">
<form action="https://zumic.com/account/registration" name="reg-form" class="reg-form submit-js" method="POST">
<input type="hidden" name="_token" value="UHriw1dMSNgpsYDx4D9u9PQAshd4t5yMr1jhx7tg"> <input type="hidden" name="recaptcha" class="recaptcha">
<div>
<div id="error-block-reg" class="input-row">
<label class="error-label" id="error-message-reg"></label>
</div>
<div class="input-row">
<label>
Your Email
</label>
<input id="email-reg" required type="email" name="email" placeholder="johnsmith@email.com">
</div>
<div class="input-row mod-pwd">
<label>
Your Password
</label>
<input id="password-reg" required type="password" name="password" placeholder="Enter Your Password">
<a class="ico show-pwd" href="#"><i class="icon-eye"></i></a>
</div>
</div>
<div class="cb-input-row">
<input id="receive-news" checked name="weekly_mails" type="checkbox">
<label for="receive-news">
Receive Weekly Newsletter.
</label>
</div>
<div class="input-row text-center btn-input-row">
<button class="css_spinner cursor_wait el-button mod-shadow mod-md min-330 btn-register" type="submit">
<span class="active">Register</span>
</button>
</div>
<div class="login-soc">
<div class="login-soc-txt">
or Log In With
</div>
<div class="login-soc-links row">
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-fb" href="https://zumic.com/account/social_login/facebook">
<span><i class="icon-facebook"></i></span>
<span>Facebook</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-gp" href="https://zumic.com/account/social_login/google">
<span><i class="icon-google-p"></i></span>
<span>Google</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-tw" href="https://zumic.com/account/social_login/twitter">
<span><i class="icon-twitter"></i></span>
<span>Twitter</span>
</a>
</div>
</div>
</div>
</form>
</div>
</div>
<div class="cookies">
<div class="pic"></div>
<div class="text">
Registration and login will only work if you allow cookies. Please check your settings and try again.
<br /><br />
<a class="js-close-cookies el-button mod-black mod-sm min-160 nohover"><span>OK</span></a>
</div>
<a class="close" href="#"></a>
</div>
</div>
</div>






<div class="remodal venue-modal" data-remodal-id="venue-modal">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="modal-content">
<img class="lazy" data-src="/assets/img/seating-chat.png" data-srcset="/assets/img/seating-chat.png" alt="seating chart">
</div>
</div>

<div class="remodal venue-modal" data-remodal-id="image-preview-modal">
<button data-remodal-action="close" class="remodal-close solid"></button>
<div class="modal-content"></div>
</div>

<div class="remodal forgotpwd-modal" id="forgotpwd-form" data-remodal-id="forgotpwd-modal">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="modal-content">
<form action="https://zumic.com/account/restore" id="forgot-password-form" name="forgotpwd-form" class="login-form submit-js" method="POST">
<input type="hidden" name="recaptcha" class="recaptcha">
<div class="input-row">
<div class="input-row-input">
<label>
Please, enter your e-mail
</label>
<input type="text" name="email" placeholder="E-mail" value="">
</div>
</div>
<div class="modal-btns">
<input type="submit" class="button mod-modal-ok" value="Done" />
<button data-remodal-action="cancel" class="button mod-modal-cancel">Cancel
</button>
</div>
</form>
</div>
</div>



<div id="CAPTCHA_KEY" data-value="6Lfg66IZAAAAANSSvGM9V3aJaPVMOZRq6ZJMy-wK"></div>

</div>

<script async defer src="/assets/js/bundle-article-libs.js?v=1.1.1.4.0802221238" type="text/javascript"></script>
<style>
    @font-face {
        font-family: "font-icon";
        src: url("/assets/css/fonts/font-icon/font-icon.eot");
        src: url("/assets/css/fonts/font-icon/font-icon.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/font-icon/font-icon.woff") format("woff"), url("/assets/css/fonts/font-icon/font-icon.ttf") format("truetype"), url("/assets/css/fonts/font-icon/font-icon.svg#font-icon") format("svg");
        font-weight: normal;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Light.eot");
        src: url("/assets/css/fonts/Lato-Light.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Light.woff") format("woff"), url("/assets/css/fonts/Lato-Light.ttf") format("truetype"), url("/assets/css/fonts/Lato-Light.svg#Lato-Light") format("svg");
        font-weight: 300;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Regular.eot");
        src: url("/assets/css/fonts/Lato-Regular.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Regular.woff") format("woff"), url("/assets/css/fonts/Lato-Regular.ttf") format("truetype"), url("/assets/css/fonts/Lato-Regular.svg#Lato-Regular") format("svg");
        font-weight: 400;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Italic.eot");
        src: url("/assets/css/fonts/Lato-Italic.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Italic.woff") format("woff"), url("/assets/css/fonts/Lato-Italic.ttf") format("truetype"), url("/assets/css/fonts/Lato-Italic.svg#Lato-Italic") format("svg");
        font-weight: 400;
        font-style: italic;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Bold.eot");
        src: url("/assets/css/fonts/Lato-Bold.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Bold.woff") format("woff"), url("/assets/css/fonts/Lato-Bold.ttf") format("truetype"), url("/assets/css/fonts/Lato-Bold.svg#Lato-Bold") format("svg");
        font-weight: 700;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Black.eot");
        src: url("/assets/css/fonts/Lato-Black.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Black.woff") format("woff"), url("/assets/css/fonts/Lato-Black.ttf") format("truetype"), url("/assets/css/fonts/Lato-Black.svg#Lato-Black") format("svg");
        font-weight: 900;
        font-style: normal;
        font-display: swap;
    }
</style>

</body>
</html>
