<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<base href="/">
<meta name="csrf-token" content="ig33pZ5clorJQ7DEuib7dAilqpsDr79pxvXwxaHl">
<meta name="HandheldFriendly" content="True">
<meta name="MobileOptimized" content="320">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
<script src="/cdn-cgi/apps/head/7d4GV02yB8UdnoUCk4VPVdvY-v4.js"></script><link rel="apple-touch-icon" sizes="57x57" href="/favicon/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/favicon/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/favicon/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/favicon/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/favicon/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/favicon/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/favicon/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/favicon/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/favicon/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="/favicon/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="/favicon/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon/favicon-16x16.png">
<link rel="manifest" href="/favicon/manifest.json">
<link rel="preload" href="/assets/css/fonts/Lato-Bold.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/Lato-Regular.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/Lato-Black.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/Lato-Italic.woff" as="font" type="font/woff" crossorigin>
<link rel="preload" href="/assets/css/fonts/font-icon/font-icon.woff" as="font" type="font/woff" crossorigin>
<style>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</style>
<script>
    /**
     * Load Firebase Component
     */
    function loadModule() {
        return new Promise(resolve => {
            const script = document.createElement('script');
            script.src = 'https://www.gstatic.com/firebasejs/5.2.0/firebase.js';
            script.async = true;
            script.defer = true;
            script.onload = () => resolve();
            script.onerror = () => {
                throw new Error();
            };
            document.head.appendChild(script);
        });
    }

    loadModule() // <-- Output firebase-app from https://github.com/firebase/firebase-js-sdk/pull/15
        .then(() => {
            firebase.initializeApp({
                apiKey: "AIzaSyCGC3cf0LlHNT27Fm_KtV0opMUCw3i3V7k",
                authDomain: "zumic-mobile-app-notifications.firebaseapp.com",
                databaseURL: "https://zumic-mobile-app-notifications.firebaseio.com",
                projectId: "zumic-mobile-app-notifications",
                storageBucket: "zumic-mobile-app-notifications.appspot.com",
                messagingSenderId: "792731844860"
            });
        });

    function initMap() {
        if (document.getElementById('location-autocomplete')) {
            setTimeout(function () {
                console.log('init map');
                googleInit();
            }, 2000);
        }
    }

    if ('serviceWorker' in navigator) {
        navigator.serviceWorker.register('/sw.js?v=1594992418', {scope: '/'})
            .then(function (registration) {
                console.log('Service Worker Registered');
            })
            .catch(error => console.log('SW error: ' + error));

        navigator.serviceWorker.ready.then(function (registration) {
            console.log('Service Worker Ready');
        });
    } else {
        console.log('Service Worker registration error');
    }
</script>
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/favicon/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">
<title>Highly Suspect Extend 2023 Tour Dates: Tickets On Sale | Zumic | Music News, Tour Dates, Ticket Presale Info, and More</title>
<meta name="description" content="Headlining shows; opening for Muse. This week, Highly Suspect added 2023 tour dates to their schedule.  Billed as Ice Cold Winter, the newly planned headlining shows are set at American venues coast to coast from February into April. The opening act will be fellow Massachusetts alt rockers Dead ...">
<meta name="original-source" content="https://zumic.com/highly-suspect-extend-2023-tour-dates-tickets-on-sale">
<meta name="robots" content="index">
<meta property="fb:app_id" content="421078361357832">
<meta property="og:locale" content="en_US">
<meta property="og:title" content="Highly Suspect Extend 2023 Tour Dates: Tickets On Sale | Zumic | Music News, Tour Dates, Ticket Presale Info, and More">
<meta property="og:type" content="article">
<meta property="og:description" content="Headlining shows; opening for Muse. This week, Highly Suspect added 2023 tour dates to their schedule.  Billed as Ice Cold Winter, the newly planned headlining shows are set at American venues coast to coast from February into April. The opening act will be fellow Massachusetts alt rockers Dead ...">
<meta property="og:url" content="https://zumic.com/highly-suspect-extend-2023-tour-dates-tickets-on-sale">
<meta property="og:site_name" content="Zumic">
<meta property="og:updated_time" content="2022-11-19T10:20:04-05:00">
<meta property="og:image:width" content="1200">
<meta property="og:image:height" content="627">
<meta property="og:image" content="https://zumic.com/wp-content/uploads/highly-suspect-2023-usa-tour-dates-tickets.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Highly Suspect Extend 2023 Tour Dates: Tickets On Sale | Zumic | Music News, Tour Dates, Ticket Presale Info, and More">
<meta name="twitter:description" content="Headlining shows; opening for Muse. This week, Highly Suspect added 2023 tour dates to their schedule.  Billed as Ice Cold Winter, the newly planned headlining shows are set at American venues coast to coast from February into April. The opening act will be fellow Massachusetts alt rockers Dead ...">
<meta name="twitter:site" content="@zumic">
<meta name="twitter:image" content="https://zumic.com/wp-content/uploads/highly-suspect-2023-usa-tour-dates-tickets.jpg">
<meta name="twitter:image:alt" content="Highly Suspect Extend 2023 Tour Dates: Tickets On Sale | Zumic | Music News, Tour Dates, Ticket Presale Info, and More">
<meta property="article:section" content="Concert Announcements">
<meta property="article:published_time" content="2022-11-18T12:28:29-05:00">
<meta property="article:publisher" content="https://www.facebook.com/zumicnews">
<meta property="article:modified_time" content="2022-11-19T10:20:04-05:00">
<meta property="article:tag" content="Highly Suspect">
<meta property="article:tag" content="Alt Rock">
<meta property="article:tag" content="Blues Rock">
<meta property="article:tag" content="Grunge">
<meta property="article:tag" content="Hard Rock">
<meta property="article:tag" content="Hip Hop">
<meta property="news_keywords" content="highly suspect, alt rock, blues rock, grunge, hard rock, hip hop, music, tickets, presale, entertainment, arts, tv, celebrities, lifestyle, culture">
<link rel="canonical" href="https://zumic.com/highly-suspect-extend-2023-tour-dates-tickets-on-sale">
<link rel="dns-prefetch" href="//s.w.org">
<link rel="amphtml" href="https://zumic.com/highly-suspect-extend-2023-tour-dates-tickets-on-sale/amp">
<script type="application/ld+json">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</script>
</head>
<body>


<div id="page-wrapper" class="page-wrapper homepage-wrap">

<header id="header" class="wrapper header fixed ">
<div class="header-top">
<div class="container">
<a href="https://zumic.com" class="logo">
<img class="lazy" data-src="/assets/img/logo.png" data-srcset="/assets/img/logo.png" alt="Zumic">
<img class="lazy" data-src="/assets/img/s-logo.png" data-srcset="/assets/img/s-logo.png" alt="Zumic">
</a>
<a class="header-top-menu-trigger js-header-top-menu-trigger">
<i class="icon-menulines"></i>
<i class="icon-mcross"></i>
</a>
<div class="header-top-menu">
<ul>
<li>
<a href="https://zumic.com/explore">Explore</a>
</li>
<li class="nested">
<a href="https://zumic.com/local-events">Local concerts</a>
<span class="nested-trigger"></span>
<ul>
<li>
<a href="https://zumic.com/local-events/new-additions">New Additions</a>
</li>
 <li>
<a href="https://zumic.com/local-events/popular">Popular</a>
</li>
</ul>
</li>
<li class="nested">
<a href="https://zumic.com/new-music">New music</a>
<span class="nested-trigger"></span>
<ul>
<li>
<a href="https://zumic.com/new-music">New Additions</a>
</li>
<li>
<a href="https://zumic.com/new-music/popular">Popular</a>
</li>
</ul>
</li>
</ul>
</div>
<a id="login-btn" href="https://zumic.com/account/login" class="header-login button mod-login">Login/Register</a>
<div class="header-search" data-module="search-form">
<div class="header-search-trigger">
<i class="icon-lup"></i>
</div>
<form action="https://zumic.com/search" method="get">

<input class="header-search-txt" type="text" name="query" placeholder="Search concerts, music and artists" value="">
<div class="result-search-head-wrap">
<div class="result-search-head"></div>
<div class="result-search-footer">
<a href="#" class="link-view-all">View all results for '<span>alt</span>'</a>
</div>
</div>
<button class="header-search-submit" type="submit">
<i class="icon-lup"></i>
</button>
<span class="header-search-close js-header-search-close">
<img src="/assets/img/cross.png" alt="close search">
</span>
</form>
</div>
</div>
</div>
<div class="header-page-overlay"></div>
</header>

<div id="page-body" class="page-body music-article-wrap tour-article-wrap">
<div class="maincontent">
<div class="topblock">
<div class="img-wrap"></div>
<div class="topblock-inner">
<div class="container">
</div>
</div>
</div>
<div class="mod-topoffset">
<div class="container">
<section class="article">
<div class="row">
<div class="col-xs-12 col-sm-8">
<div class="music-article">
<div class="music-article-top">
<div class="row">
<div class="vbottom col-xs-12 col-sm-12 col-md-12">
<div class="music-article-top-hint">
Tickets
</div>
<h1 class="word-wrap-site">Highly Suspect Extend 2023 Tour Dates: Tickets On Sale</h1>
</div>
<div class="vbottom col-xs-12 col-sm-12 col-md-12" style="margin-top: 15px; clear:both;">
<div class="music-article-top-subheader">
Headlining shows; opening for Muse
</div>
<div class="stat-item stat-fav" data-module="star_rating" data-button="favorite_article" data-article-id="24611" data-auth="">
</div>
</div>
</div>
<div class="music-article-user">
<div class="row">
<div class="col-xs-12 col-md-6 vcenter">
<span class="user-pic">
<a href="/author/fmarano" rel="nofollow">
<img class="lazy" data-src="https://www.gravatar.com/avatar/a723777af1ba7fd609f86cec1925730f?d=https%3A%2F%2Fzumic.com%2Fassets%2Fimg%2Fzumic-square.png&amp;s=200" alt="Francesco Marano">
</a>
</span>
<div class="user-txt">
<h3>
<a href="/author/fmarano">
by Francesco Marano
</a>
</h3>
<h5>
Published November 18, 2022
</h5>
</div>
</div>
<div class="col-xs-12 col-md-6 vcenter">
<div class="user-soc">
<div data-module="sharing-socials">
<div id="share" class="social-likes" data-counters="no">
<div title="Share link on Facebook" class="soclink facebook">
<i class="icon-facebook"></i>
</div>
<div title="Share link on Twitter" class="soclink twitter">
<i class="icon-twitter"></i>
</div>
<a class="soclink" href="https://zumic.com/account/login" id="share-with-email" title="Share with email">
<i class="icon-mail"></i>
</a>
</div>
<div class="remodal feedback-modal" data-remodal-id="share-with-email-modal">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="area-heading">
<div class="area-heading-title">
Share
</div>
</div>
<form id="share-form" name="shareform" action="https://zumic.com/send-email">
<div class="share-modal-txt "></div>
<div class="input-row">
<div class="input-row el-contact-form ">
<input type="text" name="sender_name" placeholder="Type your name" value="">
</div>
</div>
<div class="input-row" style="display: none">
<div class="input-row el-contact-form">
<input type="text" name="sender_email" placeholder="Type your email*" value="">
</div>
</div>
<div class="input-row">
<div class="input-row el-contact-form ">
<input type="text" name="recipient" placeholder="Type recipient email*" value="">
</div>
</div>
<textarea name="user_message" placeholder="Add a message to send with this article"></textarea>
<input type="hidden" name="reference" value="https://zumic.com/highly-suspect-extend-2023-tour-dates-tickets-on-sale">
<div class="modal-btns">


<input type="submit" value="Send" class="button mod-modal-ok">
</div>
</form>
</div>

</div>
</div>
</div>
</div>
</div>
</div>
<div class="article-content">
<div class="music-article-maincontent ctext">
<p style="text-align:center"><img alt="" height="350" src="/wp-content/uploads/highly-suspect-2023-usa-tour-dates-tickets.jpg" width="525" /></p>
<p>This week, Highly Suspect added 2023 tour dates to their schedule.</p>
<p>Billed as <em>Ice Cold Winter</em>, the newly planned headlining shows are set at American venues coast to coast from February into April. The opening act will be fellow Massachusetts alt rockers Dead Poet Society. In early April, Highly Suspect join Evanescence as opening acts for Muse&#39;s North American tour.</p>
<h2>Highly Suspect All Tour Dates and Tickets</h2>
<div class="consert-area mod-ticket">
<div class="consert-area-row">
<div class="ticket-date">
Feb 3
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-revolution-live-in-fort-lauderdale-on-feb-03-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-revolution-live-in-fort-lauderdale-on-feb-03-2023-1-1-1">
Highly Suspect and Dead Poet Society at Revolution Live
</a>
</div>
<div class="event-item-descr-loc">
<span>Revolution Live</span>
Fort Lauderdale, FL
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-revolution-live-in-fort-lauderdale-on-feb-03-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
 Feb 4
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-house-of-blues-orlando-in-orlando-on-feb-04-2023-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-house-of-blues-orlando-in-orlando-on-feb-04-2023-1-1">
Highly Suspect and Dead Poet Society at House Of Blues - Orlando
</a>
</div>
<div class="event-item-descr-loc">
<span>House Of Blues - Orlando</span>
Lake Buena Vista, FL
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-house-of-blues-orlando-in-orlando-on-feb-04-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 5
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-club-la-in-destin-on-feb-05-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-club-la-in-destin-on-feb-05-2023-1-1-1">
Highly Suspect and Dead Poet Society at Club LA
</a>
</div>
<div class="event-item-descr-loc">
<span>Club LA</span>
Destin, FL
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-club-la-in-destin-on-feb-05-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 7
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-soul-kitchen-in-mobile-on-feb-07-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-soul-kitchen-in-mobile-on-feb-07-2023-1-1-1">
Highly Suspect and Dead Poet Society at Soul Kitchen
</a>
</div>
<div class="event-item-descr-loc">
<span>Soul Kitchen</span>
Mobile, AL
</div>
 </div>
</div>
<div>
<a href="/events/highly-suspect-at-soul-kitchen-in-mobile-on-feb-07-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 9
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-tipitinas-in-new-orleans-on-feb-09-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-tipitinas-in-new-orleans-on-feb-09-2023-1-1-1">
Highly Suspect and Dead Poet Society at Tipitinas
</a>
</div>
<div class="event-item-descr-loc">
<span>Tipitinas</span>
New Orleans, LA
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-tipitinas-in-new-orleans-on-feb-09-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 10
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-and-dead-poet-society-at-black-lodge-in-memphis-tn-on-feb-10-2023-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-and-dead-poet-society-at-black-lodge-in-memphis-tn-on-feb-10-2023-1">
Highly Suspect and Dead Poet Society at Black Lodge
</a>
</div>
<div class="event-item-descr-loc">
<span>Black Lodge</span>
Memphis, TN
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-and-dead-poet-society-at-black-lodge-in-memphis-tn-on-feb-10-2023-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 11
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-mark-c-smith-concert-hall-von-braun-center-in-huntsville-on-feb-11-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-mark-c-smith-concert-hall-von-braun-center-in-huntsville-on-feb-11-2023-1-1-1">
Highly Suspect and Dead Poet Society at Von Braun Center Concert Hall
</a>
</div>
<div class="event-item-descr-loc">
<span>Von Braun Center Concert Hall</span>
Huntsville, AL
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-mark-c-smith-concert-hall-von-braun-center-in-huntsville-on-feb-11-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 14
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-mercury-ballroom-in-louisville-on-feb-14-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-mercury-ballroom-in-louisville-on-feb-14-2023-1-1-1">
Highly Suspect and Dead Poet Society at Mercury Ballroom
</a>
</div>
<div class="event-item-descr-loc">
<span>Mercury Ballroom</span>
Louisville, KY
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-mercury-ballroom-in-louisville-on-feb-14-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-xl-live-in-harrisburg-on-feb-16-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-xl-live-in-harrisburg-on-feb-16-2023-1-1-1">
Highly Suspect and Dead Poet Society at XL Live
</a>
</div>
<div class="event-item-descr-loc">
<span>XL Live</span>
Harrisburg, PA
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-xl-live-in-harrisburg-on-feb-16-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 17
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-roxian-theatre-in-mckees-rocks-on-feb-17-2023-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-roxian-theatre-in-mckees-rocks-on-feb-17-2023-1-1">
Highly Suspect and Dead Poet Society at Roxian Theatre
</a>
</div>
<div class="event-item-descr-loc">
<span>Roxian Theatre</span>
McKees Rocks, PA
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-roxian-theatre-in-mckees-rocks-on-feb-17-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 18
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-and-dead-poet-society-at-rams-head-live-in-baltimore-md-on-feb-18-2023-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-and-dead-poet-society-at-rams-head-live-in-baltimore-md-on-feb-18-2023-1">
Highly Suspect and Dead Poet Society at Rams Head Live!
</a>
</div>
<div class="event-item-descr-loc">
<span>Rams Head Live!</span>
Baltimore, MD
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-and-dead-poet-society-at-rams-head-live-in-baltimore-md-on-feb-18-2023-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 21
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-manchester-music-hall-in-lexington-on-feb-21-2023-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-manchester-music-hall-in-lexington-on-feb-21-2023-1-1">
Highly Suspect and Dead Poet Society at Manchester Music Hall
</a>
</div>
<div class="event-item-descr-loc">
<span>Manchester Music Hall</span>
Lexington, KY
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-manchester-music-hall-in-lexington-on-feb-21-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 23
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-and-dead-poet-society-at-clyde-theatre-in-fort-wayne-in-on-feb-23-2023-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-and-dead-poet-society-at-clyde-theatre-in-fort-wayne-in-on-feb-23-2023-1">
Highly Suspect and Dead Poet Society at Clyde Theatre
</a>
</div>
<div class="event-item-descr-loc">
<span>Clyde Theatre</span>
Fort Wayne, IN
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-and-dead-poet-society-at-clyde-theatre-in-fort-wayne-in-on-feb-23-2023-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 24
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-turner-hall-ballroom-in-milwaukee-on-feb-24-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-turner-hall-ballroom-in-milwaukee-on-feb-24-2023-1-1-1">
Highly Suspect and Dead Poet Society at Turner Hall Ballroom
</a>
</div>
<div class="event-item-descr-loc">
<span>Turner Hall Ballroom</span>
Milwaukee, WI
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-turner-hall-ballroom-in-milwaukee-on-feb-24-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 25
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-the-sylvee-wi-in-madison-on-feb-25-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-the-sylvee-wi-in-madison-on-feb-25-2023-1-1-1">
Highly Suspect and Dead Poet Society at The Sylvee
</a>
</div>
<div class="event-item-descr-loc">
<span>The Sylvee</span>
Madison, WI
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-the-sylvee-wi-in-madison-on-feb-25-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Feb 28
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-and-dead-poet-society-at-the-castle-theatre-in-bloomington-il-on-feb-28-2023-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-and-dead-poet-society-at-the-castle-theatre-in-bloomington-il-on-feb-28-2023-1-1">
Highly Suspect and Dead Poet Society at The Castle Theatre
</a>
</div>
<div class="event-item-descr-loc">
<span>The Castle Theatre</span>
Bloomington, IL
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-and-dead-poet-society-at-the-castle-theatre-in-bloomington-il-on-feb-28-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 2
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-the-pageant-in-saint-louis-on-mar-02-2023-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-the-pageant-in-saint-louis-on-mar-02-2023-1-1">
Highly Suspect and Dead Poet Society at The Pageant
</a>
</div>
<div class="event-item-descr-loc">
<span>The Pageant</span>
St. Louis, MO
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-the-pageant-in-saint-louis-on-mar-02-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
 Mar 3
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-at-egyptian-room-at-old-national-centre-in-indianapolis-on-mar-03-2023-1-1-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-at-egyptian-room-at-old-national-centre-in-indianapolis-on-mar-03-2023-1-1-1">
Highly Suspect and Dead Poet Society at Old National Centre
</a>
</div>
<div class="event-item-descr-loc">
<span>Old National Centre</span>
Indianapolis, IN
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-at-egyptian-room-at-old-national-centre-in-indianapolis-on-mar-03-2023-1-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Mar 4
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/highly-suspect-and-dead-poet-society-at-promowest-pavilion-at-ovation-in-newport-ky-on-mar-4-2023-1">
Highly Suspect and Dead Poet Society
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/highly-suspect-and-dead-poet-society-at-promowest-pavilion-at-ovation-in-newport-ky-on-mar-4-2023-1">
Highly Suspect and Dead Poet Society at PromoWest Pavilion at Ovation
</a>
</div>
<div class="event-item-descr-loc">
<span>PromoWest Pavilion at Ovation</span>
Newport, KY
</div>
</div>
</div>
<div>
<a href="/events/highly-suspect-and-dead-poet-society-at-promowest-pavilion-at-ovation-in-newport-ky-on-mar-4-2023-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 2
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-desert-diamond-casino-in-sahuarita-az-on-apr-2-2023-1-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-desert-diamond-casino-in-sahuarita-az-on-apr-2-2023-1-1">
Muse, Evanescence, and Highly Suspect at Desert Diamond Casino
 </a>
</div>
<div class="event-item-descr-loc">
<span>Desert Diamond Casino</span>
Sahuarita, AZ
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-desert-diamond-casino-in-sahuarita-az-on-apr-2-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 4
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-ball-arena-in-denver-co-on-apr-4-2023-1-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-ball-arena-in-denver-co-on-apr-4-2023-1-1">
Muse, Evanescence, and Highly Suspect at Ball Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Ball Arena</span>
Denver, CO
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-ball-arena-in-denver-co-on-apr-4-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 6
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-cryptocom-arena-in-los-angeles-ca-on-apr-6-2023-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-cryptocom-arena-in-los-angeles-ca-on-apr-6-2023-1">
Muse, Evanescence, and Highly Suspect at Crypto.com Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Crypto.com Arena</span>
Los Angeles, CA
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-cryptocom-arena-in-los-angeles-ca-on-apr-6-2023-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 8
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-t-mobile-arena-in-las-vegas-nv-on-apr-8-2023-1">
Muse, Evanescence, and Highly Suspect
 </a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-t-mobile-arena-in-las-vegas-nv-on-apr-8-2023-1">
Muse, Evanescence, and Highly Suspect at T-Mobile Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>T-Mobile Arena</span>
Las Vegas, NV
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-t-mobile-arena-in-las-vegas-nv-on-apr-8-2023-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 10
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-pechanga-arena-san-diego-in-san-diego-ca-on-apr-10-2023-1-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-pechanga-arena-san-diego-in-san-diego-ca-on-apr-10-2023-1-1">
Muse, Evanescence, and Highly Suspect at Pechanga Arena - San Diego
</a>
</div>
<div class="event-item-descr-loc">
<span>Pechanga Arena - San Diego</span>
San Diego, CA
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-pechanga-arena-san-diego-in-san-diego-ca-on-apr-10-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 12
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-honda-center-in-anaheim-ca-on-apr-12-2023-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-honda-center-in-anaheim-ca-on-apr-12-2023-1">
Muse, Evanescence, and Highly Suspect at Honda Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Honda Center</span>
Anaheim, CA
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-honda-center-in-anaheim-ca-on-apr-12-2023-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 14
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-oakland-arena-in-oakland-ca-on-apr-14-2023-1-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-oakland-arena-in-oakland-ca-on-apr-14-2023-1-1">
Muse, Evanescence, and Highly Suspect at Oakland Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Oakland Arena</span>
Oakland, CA
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-oakland-arena-in-oakland-ca-on-apr-14-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 16
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-moda-center-in-portland-or-on-apr-16-2023-1-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-moda-center-in-portland-or-on-apr-16-2023-1-1">
Muse, Evanescence, and Highly Suspect at Moda Center
</a>
</div>
<div class="event-item-descr-loc">
<span>Moda Center</span>
Portland, OR
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-moda-center-in-portland-or-on-apr-16-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 18
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-climate-pledge-arena-in-seattle-wa-on-apr-18-2023-1-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-climate-pledge-arena-in-seattle-wa-on-apr-18-2023-1-1">
Muse, Evanescence, and Highly Suspect at Climate Pledge Arena
 </a>
</div>
<div class="event-item-descr-loc">
<span>Climate Pledge Arena</span>
Seattle, WA
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-climate-pledge-arena-in-seattle-wa-on-apr-18-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
<div class="consert-area-row">
<div class="ticket-date">
Apr 20
</div>
<div class="event-item-descr-place mobile">
<a class="consert-area-link" rel="nofollow" href="/events/muse-and-evanescence-at-vivint-arena-in-salt-lake-city-ut-on-apr-20-2023-1-1">
Muse, Evanescence, and Highly Suspect
</a>
</div>
<div class="ticket-info">
<div class="consert-area-loc">
<div class="event-item-descr-place">
<a class="consert-area-link" href="/events/muse-and-evanescence-at-vivint-arena-in-salt-lake-city-ut-on-apr-20-2023-1-1">
Muse, Evanescence, and Highly Suspect at Vivint Arena
</a>
</div>
<div class="event-item-descr-loc">
<span>Vivint Arena</span>
Salt Lake City, UT
</div>
</div>
</div>
<div>
<a href="/events/muse-and-evanescence-at-vivint-arena-in-salt-lake-city-ut-on-apr-20-2023-1-1" class="el-button mod-black mod-shadow-hover min-160 js-info">
buy tickets
</a>
</div>
</div>
</div>
<h5>When do Highly Suspect 2023 tour tickets go on sale and what is the presale code?</h5>
<p>Tickets for all shows are now on sale. Keep in mind, each date is different and details are subject to change. Click through the individual concert links for more information about the show you&#39;re interested in.</p>
<p>We recommend following Highly Suspect on social media and signing up for <a href="https://www.highlysuspect.net/#!" target="_blank">the email newsletter</a> (bottom of page), in addition to checking your local venue&#39;s social media and email subscription service, to get the most up-to-date information.</p>
<p>In September the band released a new album titled <i>The Midnight Demon Club</i>. For more, check out <a href="https://zumic.com/artists/highly-suspect">Highly Suspect&#39;s Zumic artist page</a>.</p>
<p style="text-align:center"><img alt="" src="/wp-content/uploads/highly-suspect-2023-usa-tour-dates-tickets-info.jpg" /></p>
</div>
</div>
<div class="music-article-bottom">
<div class="music-article-bottom-stats">
<div class="stat-item stat-upwote item-bottom-stats" data-rating="24611" title="upvotes">
<a href="https://zumic.com/article-vote/24611" class="ico article-vote">
<i class="icon-upwote"></i>
</a>
<span class="votes">
2
</span>
</div>
<div class="stat-item stat-views" title="views">
<span class="ico">
<i class="icon-eye"></i>
</span>
<span>
89
</span>
</div>
</div>
<div class="music-article-bottom-tags">
<div class="tag-caption area-heading">
<span class="area-heading-title">artists</span>
</div>
<a href="/artists/highly-suspect" class="tag">Highly Suspect</a>
<div class="tag-caption area-heading">
<span class="area-heading-title">genres</span>
</div>
<a href="/genres/rock/alt-rock" class="tag">
Alt Rock
</a>
<a href="/genres/rock/blues-rock" class="tag">
Blues Rock
</a>
<a href="/genres/rock/hard-rock/grunge" class="tag">
Grunge
</a>
<a href="/genres/hard-rock" class="tag">
Hard Rock
</a>
<a href="/genres/hip-hop" class="tag">
Hip Hop
</a>
</div>
</div>

<div class="comments">
<div class="comments-top">
<div class="area-heading">
<div class="area-heading-title">
сomments
</div>
<div class="area-heading-btn">
<label>
See an error?
</label>
<span data-module="feedback-front">
<a href="https://zumic.com/account/login" id="leave-feedback-button" class="el-button mod-shadow min-160">
<span>Send Feedback</span>
</a>
</span>
</div>
</div>
</div>

<div data-module="disqus" data-key="zumic">
<div class="disqus-comments">
<div id='disqus_thread'></div>
</div>
</div>
</div>
</div>
</div>


<div class="sidebar col-xs-12 col-sm-4">
<div class="el-sidebar-poster">
</div>

<div class="events-results">

<div class="named-event">
<div class="named-event-top">
<a href="/artists/highly-suspect">
<div class="named-event-top-pic">
<img class="lazy" data-src="/wp-content/uploads/highly-suspect-tour-dates-music-news.jpg" alt="image for artist Highly Suspect">
</div>
<div class="named-event-top-name">
Highly Suspect
</div>
</a>
</div>
</div>
</div>
<div class="named-event sponsors-links">
<div class="named-event-top">
<div class="named-event-top-name text-center">
Powered By
</div>
</div>
<div class="row text-center">
<a href="http://ticketmaster.evyy.net/c/253533/264167/4272" target="_blank">
<img class="lazy" data-src="/assets/img/p1.png" alt="image for ticketmaster">
</a>
<a href="https://shareasale.com/r.cfm?b=1128188&amp;u=701549&amp;m=76847&amp;urllink=https%3A%2F%2Fwww.scorebig.com" target="_blank">
<img class="lazy" data-src="/thumbs/wp-content/uploads/scorebig-tickets-info_200x80.png" alt="image for ticketnetwork">
</a>
<a href="https://ticketnetwork.7eer.net/c/231399/120057/2322" target="_blank">
<img class="lazy" data-src="/assets/img/p3.png" alt="image for ticketnetwork">
</a>
<a href="https://prf.hn/click/camref:1101la8u4/destination:https%3A%2F%2Fwww.stubhub.com" target="_blank">
<img class="lazy" data-src="/assets/img/p4.png" alt="image for stubhub">
</a>
</div>
</div>
<div class="el-sidebar-poster">
</div>

</div> 
</div>
</section>
</div>
<div class="article-detail-recomended">
<div class="container">
<div class="area-heading">
<div class="area-heading-title">
recommended music
</div>
</div>
<div class="maincontent-inner-list row">

<div class="item  col-xs-12 col-sm-4 ">
<div class="item-inner">
<span class="item-mark">
<i class="icon-z-mark"></i>
</span>
<a href="/highly-suspect-adds-2022-tour-dates-ticket-presale-code-and-on-sale-info" class="article-img-container">
<div class="article-img-background lazy " data-bg="url(/thumbs/wp-content/uploads/highly-suspect-tour-dates-tickets-info_x300.jpg)">
</div>
<img class="article-img lazy" data-src="/thumbs/wp-content/uploads/highly-suspect-tour-dates-tickets-info_x300.jpg" alt="image for article Highly Suspect Adds 2022 Tour Dates: Ticket Presale Code &amp; On-Sale Info">
</a>
<div class="item-mid">
<div class="item-date">
July 14, 2022
</div>
<div class="item-title">
<a title="Highly Suspect Adds 2022 Tour Dates: Ticket Presale Code &amp; On-Sale Info" href="/highly-suspect-adds-2022-tour-dates-ticket-presale-code-and-on-sale-info">
Highly Suspect Adds 2022 Tour Dates: Ticket Presale Code &amp; On-Sal...
</a>
</div>
<div class="item-tags">
<a href="/highly-suspect-adds-2022-tour-dates-ticket-presale-code-and-on-sale-info" class="tag active">Tickets</a>
<a href="/genres/rock/alt-rock" class="tag">
Alt Rock
</a>
<a href="/genres/rock/blues-rock" class="tag">
Blues Rock
</a>
<a href="/genres/rock/hard-rock/grunge" class="tag">
Grunge
</a>
<a href="/genres/hard-rock" class="tag">
Hard Rock
</a>
<a href="/genres/hip-hop" class="tag">
Hip Hop
</a>
<a href="/artists/highly-suspect" class="tag">
Highly Suspect
</a>
</div>
</div>
<div class="item-bottom">
<div class="item-bottom-stats" data-rating="18624" data-count_rating="https://zumic.com/article-count/18624">
<div class="stat-item stat-upwote" title="upvotes">
<a href="https://zumic.com/account/login-error-upvote" class="ico article-vote">
<i class="icon-upwote"></i>
</a>
<span class="votes">
1
</span>
</div>
<div class="stat-item stat-views" title="views">
<span class="ico">
<i class="icon-eye"></i>
</span>
<span class="views">
579
</span>
</div>
</div>
</div>
</div>
</div>


<div class="item  col-xs-12 col-sm-4 ">
<div class="item-inner">
<span class="item-mark">
<i class="icon-waves"></i>
</span>
<a href="/name-human-highly-suspect-youtube-music-video" class="article-img-container">
<div class="article-img-background lazy " data-bg="url(/assets/img/zumic_ico_bg.png)">
</div>
<img class="article-img lazy" data-src="/assets/img/zumic_ico_bg.png" alt="image for article &quot;My Name Is Human&quot; - Highly Suspect [YouTube Music Video]">
</a>
<div class="item-mid">
<div class="item-date">
May 23, 2017
</div>
<div class="item-title">
<a title="&quot;My Name Is Human&quot; - Highly Suspect [YouTube Music Video]" href="/name-human-highly-suspect-youtube-music-video">
&quot;My Name Is Human&quot; - Highly Suspect [YouTube Music Video]
</a>
</div>
<div class="item-tags">
<a href="/name-human-highly-suspect-youtube-music-video" class="tag active">Music</a>
<a href="/genres/rock/alt-rock" class="tag">
Alt Rock
</a>
<a href="/artists/highly-suspect" class="tag">
Highly Suspect
</a>
<a href="https://zumic.com/search-by-tag?tag=Massachusetts" class="tag">
Massachusetts
</a>
<a href="https://zumic.com/search-by-tag?tag=Official%2520Music%2520Video" class="tag">
Official Music Video
</a>
</div>
</div>
<div class="item-bottom">
<div class="item-bottom-stats" data-rating="8901" data-count_rating="https://zumic.com/article-count/8901">
<div class="stat-item stat-upwote" title="upvotes">
<a href="https://zumic.com/account/login-error-upvote" class="ico article-vote">
<i class="icon-upwote"></i>
</a>
<span class="votes">
1
</span>
</div>
<div class="stat-item stat-views" title="views">
<span class="ico">
<i class="icon-eye"></i>
</span>
<span class="views">
979
</span>
</div>
</div>
</div>
</div>
</div>

</div>
</div>
</div>

<div class="text-center optional-button">
<a href="#" class="button el-pointer-btn mod-top">
<span>
Back to top
</span>
<i class="icon-dotarr"></i>
</a>
</div>

</div>
</div>
</div>

<footer id="footer" class="wrapper footer">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-2 footer-logo">
<a class="" href="https://zumic.com">
<img class="lazy" data-src="/assets/img/f-logo.png" data-srcset="/assets/img/f-logo.png" alt="Zumic">
</a>
</div>
<div class="col-xs-12 col-sm-12 col-md-6 footer-nav">
<a href="#" class="footer-nav-control js-footer-nav-control">
QUICK LINKS
<span class="ico-plus"></span>
</a>
<div class="footer-nav-menu">
<div class="row">
<ul>
<li class="col-sm-4 col-md-4 ">
<a href="/who-we-are">Who We Are</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/explore">Explore</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="/jobs">Jobs</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/faq">FAQ</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/local-events">Local Concerts</a>
</li>
<li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/contact-us">Contact Us</a>
</li>
 <li class="col-sm-4 col-md-4 ">
<a href="https://zumic.com/new-music">New Music</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-xs-12 col-sm-12 col-md-4 footer-form">
<div class="footer-form-title">
Join Our Newsletter<br>
<i>Concerts, Tickets, News & More</i>
</div>
<div data-module="newsletter-form">
<div id="error-block" class="input-row">
<label class="error-label" id="error-message"></label>
</div>
<form name="footer-form-subscr" action="https://zumic.com/subscribe" id="newsletter-form" class="footer-form-subscr">
<div class="input-row">
<input class="footer-form-subscr-txt" name="email" type="text" placeholder="enter your email address">
<button type="submit" class="footer-form-subscr-submit">
</button>
</div>
</form>
</div>
</div>
</div>
</div>
<div class="container">
<div class="footer-bottom">
<div class="row">
<div class="footer-bottom-soc col-xs-12 col-md-4">
<a href="https://www.facebook.com/zumicnews" target="_blank" class="soclink">
<i class="icon-facebook"></i>
</a>
<a href="https://twitter.com/Zumic" target="_blank" class="soclink">
<i class="icon-twitter"></i>
</a>
<a href="https://www.instagram.com/zumicnews/" target="_blank" class="soclink">
<i class="icon-instagram"></i>
</a>
<a href="https://www.youtube.com/user/ZumicTube" target="_blank" class="soclink">
<i class="icon-youtube"></i>
</a>
</div>
<div class="footer-bottom-links col-xs-12 col-md-8">
<ul>
<li>© 2022 Zumic Entertainment, Inc.</li>
<li>
<a href="/terms-of-service">Terms of Service</a>
</li>
<li>
<a href="/privacy-policy">Privacy Policy</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</footer>
<div class="remodal login-modal" data-remodal-id="login-modal" style="max-width: 814px;">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="area-heading">
<div class="area-heading-title upvote-login">
You must be logged in to <span id="login-modal-title">upvote</span>.
</div>
</div>
<div class="js-login-tabs login-tabs tabs_default">
<ul class="login-tabs-tabsarea">
<li>
<a class="login-tab" href="#login-1">
<span>LOGIN</span>
</a>
</li>
<li>
<a class="login-tab" href="#login-2">
<span>Register</span>
</a>
</li>
</ul>
<div id="login-1" class="login-content">
<form action="https://zumic.com/account/login" name="login-form" class="login-form submit-js" method="POST">
<input type="hidden" name="_token" value="ig33pZ5clorJQ7DEuib7dAilqpsDr79pxvXwxaHl"> <input type="hidden" name="recaptcha" class="recaptcha">
<input type="hidden" name="recaptcha_key" value="6Lfg66IZAAAAANSSvGM9V3aJaPVMOZRq6ZJMy-wK" class="recaptcha_key">
<div>
<div id="error-block" class="input-row">
<label class="error-label" id="error-message"></label>
</div>
<div class="input-row">
<label>
Your Email
</label>
<input id="email-login" required type="email" name="email" placeholder="johnsmith@email.com">
</div>
<div class="input-row mod-pwd">
<label>
Your Password
</label>
<input id="password-login" required type="password" name="password" placeholder="Enter Your Password">
<a class="ico show-pwd" href="#">
<i class="icon-eye"></i>
</a>
</div>
</div>
<a href="https://zumic.com/account/reset_password" class="login-forgot">
Forgot Your Password?
</a>
<div class="input-row text-center btn-input-row">
<button id="btn-login" class="css_spinner cursor_wait el-button mod-shadow mod-md min-330" type="submit">
<span class="active">LOG IN</span>
</button>
</div>
<div class="login-soc">
<div class="login-soc-txt">
or Log In With
</div>
<div class="login-soc-links row">
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-fb" href="https://zumic.com/account/social_login/facebook">
<span><i class="icon-facebook"></i></span>
<span>Facebook</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-gp" href="https://zumic.com/account/social_login/google">
<span><i class="icon-google-p"></i></span>
<span>Google</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-tw" href="https://zumic.com/account/social_login/twitter">
<span><i class="icon-twitter"></i></span>
<span>Twitter</span>
</a>
</div>
</div>
</div>
</form>
</div>
<div id="login-2" class="login-content">
<form action="https://zumic.com/account/registration" name="reg-form" class="reg-form submit-js" method="POST">
<input type="hidden" name="_token" value="ig33pZ5clorJQ7DEuib7dAilqpsDr79pxvXwxaHl"> <input type="hidden" name="recaptcha" class="recaptcha">
<div>
<div id="error-block-reg" class="input-row">
<label class="error-label" id="error-message-reg"></label>
</div>
<div class="input-row">
<label>
Your Email
</label>
<input id="email-reg" required type="email" name="email" placeholder="johnsmith@email.com">
</div>
<div class="input-row mod-pwd">
<label>
Your Password
</label>
<input id="password-reg" required type="password" name="password" placeholder="Enter Your Password">
<a class="ico show-pwd" href="#"><i class="icon-eye"></i></a>
</div>
</div>
<div class="cb-input-row">
<input id="receive-news" checked name="weekly_mails" type="checkbox" style="-webkit-appearance: checkbox;margin-top: -5px;">
<label for="receive-news">
Receive Weekly Newsletter.
 </label>
</div>
<div class="input-row text-center btn-input-row">
<button class="css_spinner cursor_wait el-button mod-shadow mod-md min-330 btn-register" type="submit">
<span class="active">Register</span>
</button>
</div>
<div class="login-soc">
<div class="login-soc-txt">
or Log In With
</div>
<div class="login-soc-links row">
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-fb" href="https://zumic.com/account/social_login/facebook">
<span><i class="icon-facebook"></i></span>
<span>Facebook</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-gp" href="https://zumic.com/account/social_login/google">
<span><i class="icon-google-p"></i></span>
<span>Google</span>
</a>
</div>
<div class="col-xs-12 col-sm-4">
<a class="soclogin mod-tw" href="https://zumic.com/account/social_login/twitter">
<span><i class="icon-twitter"></i></span>
<span>Twitter</span>
</a>
</div>
</div>
</div>
</form>
</div>
</div>
<div class="cookies">
<div class="pic"></div>
<div class="text">
Registration and login will only work if you allow cookies. Please check your settings and try again.
<br /><br />
<a class="js-close-cookies el-button mod-black mod-sm min-160 nohover"><span>OK</span></a>
</div>
<a class="close" href="#"></a>
</div>
</div>






<div class="remodal venue-modal" data-remodal-id="venue-modal">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="modal-content">
<img class="lazy" data-src="/assets/img/seating-chat.png" data-srcset="/assets/img/seating-chat.png" alt="seating chart">
</div>
</div>

<div class="remodal venue-modal" data-remodal-id="image-preview-modal">
<button data-remodal-action="close" class="remodal-close solid"></button>
<div class="modal-content"></div>
</div>

<div class="remodal forgotpwd-modal" id="forgotpwd-form" data-remodal-id="forgotpwd-modal">
<button data-remodal-action="close" class="remodal-close"></button>
<div class="modal-content">
<form action="https://zumic.com/account/restore" id="forgot-password-form" name="forgotpwd-form" class="login-form submit-js" method="POST">
<input type="hidden" name="recaptcha" class="recaptcha">
<div class="input-row">
<div class="input-row-input">
<label>
Please, enter your e-mail
</label>
<input type="text" name="email" placeholder="E-mail" value="">
</div>
</div>
<div class="modal-btns">
<input type="submit" class="button mod-modal-ok" value="Done" />
<button data-remodal-action="cancel" class="button mod-modal-cancel">Cancel
</button>
</div>
</form>
</div>
</div>



<div id="CAPTCHA_KEY" data-value="6Lfg66IZAAAAANSSvGM9V3aJaPVMOZRq6ZJMy-wK"></div>

</div>

<script async defer src="/assets/js/bundle-article-libs.js?v=1.1.1.4.151120221224" type="text/javascript"></script>
<style>
    @font-face {
        font-family: "font-icon";
        src: url("/assets/css/fonts/font-icon/font-icon.eot");
        src: url("/assets/css/fonts/font-icon/font-icon.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/font-icon/font-icon.woff") format("woff"), url("/assets/css/fonts/font-icon/font-icon.ttf") format("truetype"), url("/assets/css/fonts/font-icon/font-icon.svg#font-icon") format("svg");
        font-weight: normal;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Light.eot");
        src: url("/assets/css/fonts/Lato-Light.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Light.woff") format("woff"), url("/assets/css/fonts/Lato-Light.ttf") format("truetype"), url("/assets/css/fonts/Lato-Light.svg#Lato-Light") format("svg");
        font-weight: 300;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Regular.eot");
        src: url("/assets/css/fonts/Lato-Regular.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Regular.woff") format("woff"), url("/assets/css/fonts/Lato-Regular.ttf") format("truetype"), url("/assets/css/fonts/Lato-Regular.svg#Lato-Regular") format("svg");
        font-weight: 400;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Italic.eot");
        src: url("/assets/css/fonts/Lato-Italic.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Italic.woff") format("woff"), url("/assets/css/fonts/Lato-Italic.ttf") format("truetype"), url("/assets/css/fonts/Lato-Italic.svg#Lato-Italic") format("svg");
        font-weight: 400;
        font-style: italic;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Bold.eot");
        src: url("/assets/css/fonts/Lato-Bold.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Bold.woff") format("woff"), url("/assets/css/fonts/Lato-Bold.ttf") format("truetype"), url("/assets/css/fonts/Lato-Bold.svg#Lato-Bold") format("svg");
        font-weight: 700;
        font-style: normal;
        font-display: swap;
    }

    @font-face {
        font-family: "Lato";
        src: url("/assets/css/fonts/Lato-Black.eot");
        src: url("/assets/css/fonts/Lato-Black.eot?#iefix") format("embedded-opentype"), url("/assets/css/fonts/Lato-Black.woff") format("woff"), url("/assets/css/fonts/Lato-Black.ttf") format("truetype"), url("/assets/css/fonts/Lato-Black.svg#Lato-Black") format("svg");
        font-weight: 900;
        font-style: normal;
        font-display: swap;
    }
</style>

</body>
</html>
